Loading ...

Silcon 40kva

Discussion in Data Center & Facility 3 Phase UPS started by Tom , 6/7/2018 1:51 AM
Login to follow, share, and participate in this space.
Not a member?Join now
  • Tp71
    Tom
    New Member New Member
    Tom 6/7/2018 1:51 AM

    My customer has a Silcon 40kva ups (208v). He called up a couple of weeks ago saying he had a problem with his ups. He told me he smelled something burning and thought it was the ups so he just closed the Q003 bkr on the wall mounted bypass switch. I did inform him of that it wasn't the proper procedure to put it in bypass. So someone from my company checked out the unit and found the batteries totally depleted and in need of replacement (they were old and needed replacement anyway) and also put the unit into maintenance bypass and removed the battery fuses. So I returned and replaced the batteries and proceeded to start up the ups. It started up fine, but when in normal operation, the batteries slowly start to drain (by reading the display) down to 173vdc on both sides until it goes into alarm for low dc warning and I have to go to maint bypass. The batteries don't seem to charge at all once put into normal operation (neither side will go above 195vdc). The ups gives off no alarms. When I contacted the factory, they informed me to replaced the dc caps, which I did and still has the same problem. I re-entered and checked all the values (boost charge, batt charge, etc). Ive never had this type of problem before. After a thorough inspection of the ups, there's nothing that really sticks out as what's causing this problem. The only thing I could think of is it could the battery charge board or the control board. Im thinking when the companies employee switched it to bypass incorrectly, it created a problem with the ups. Any thoughts? Thanks

  • wpasquil
    Bill
    =S= Representative
    Bill 6/8/2018 6:33 PM (in response to Tom)

    Hi,

    When you wrote you contacted the factory I assume you mean you called Schneider Electric Technical Support. If that is the case I recommend you call them back. They are the experts and will be able to assist with the next step/s. 

  • Tp71
    Tom
    New Member New Member
    Tom 6/26/2018 3:11 PM (in response to Bill)

    I did and they want to send out a  factory technician to troubleshoot it. They won't assist me as far as what component maybe causing the problem. 

  • Page 1 of 1 (3 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692