Loading ...

| Data Center & Facility 3 Phase UPS

Home » Spaces » Data Center & Facility 3 Phase UPS » discussion » General » PDU 40kW 208V Display

PDU 40kW 208V Display

Discussion in Data Center & Facility 3 Phase UPS started by Billy , 6/26/2015 10:15 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

PDU 40kW 208V Display

Subscribe to RSS
  • Billy

    The display screen on our PDU shows only a arrow curser at the top left of the screen. Tried unplugging the cable per tech support and no change. Swapped the screen out with one from a spare we have in storage with the same results. Tech support said that if the un-plug/re-plug didn't work, then we have a bad brain. We have a spare brain in the spare unit, is it "hot-swappable"?

  • ipicKedawinna

    I found an internal procedure for this which indicated:

    So, my answer would be you must power down. I double checked with someone in 3 phase support too to make sure I found the right instructions and he did confirm the PDU needs to be powered down for safety reasons.

  • Billy

    Thank you Angela,

    That is pretty much what I thought, just nice to hear it confirmed. It is one of our "problemed chilren" here which needs some attention anyway.

  • epattengill

    Hello. Is this the same 'dead brain' problem I might have on my 100K? Can you help with the location and part number of a 'brain'? It's a Symmetra PX2 with modular power and not the 'older style' with electric plugs running under the floor. Thanks!

  • wpasquil

    Eric,

    Please contact the 3 phase technical support team and they will be happy to assist you. 

    Local support contact information will be found at this link.

    https://www.apc.com/us/en/support/contact-us/index.jsp

    You may need to change the region in the upper left of the contact us web page. 

Page 1 of 1 (5 items)
Choose your language:  
powered by Communifire
Version 8.0.7598.8416