Loading ...

Power Chute Personal Edition not finding UPS | UPS Management Devices & PowerChute Software

Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Power Chute Personal Edition not finding UPS

Power Chute Personal Edition not finding UPS

Discussion in UPS Management Devices & PowerChute Software started by Martyn , 4/1/2021 6:59 PM
Login to follow, share, and participate in this space.
Not a member?Join now

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

Posted in: General

Power Chute Personal Edition not finding UPS

Subscribe to RSS
  • I have a Smart-UPS 1500i connected by USB to a Windows 10 64-bit PC; the UPS appears in Device Manager under Batteries and HID, all the relevant drivers are in place but installation fails as 'unable to locate the battery backup...'

    apcrun.exe and ValidateUPS.exe appear in the default installation directory together with six .dll files, but nothing happens when either of the exe files is double-clicked. Windows troubleshooter indicates that these are incompatible.

    What can I do to get PCPE to run?

    Attached is deview.txt from the USBDeview program.

  • Hello,

    PowerChute Personal Edition is not compatible with a Smart-UPS. You need to install PowerChute Business Edition. See Schneider Electric FAQ FA338817  or view this video https://www.youtube.com/watch?v=4E3PmZCWnfY&t=267s for assistance with installing and accessing PowerChute Business Edition Agent on Windows. 


  • Thanks for the response - installed Business Edition and it seems to be working over USB. 

  • I upgraded to PCBE version and now I get the message 'StartServiceControlDispatcher failed!' whenever I try to run pbeagent.exe - the previous version seemed to work. What can I do?

  • I have re-installed version 9.5 and get the same message. Task Manager shows that pbeagent is running, but nothing appears in the display.

  • Doh! Apologies everyone, brain malfunction - I ran pbeagent from the directory, when I run it from Windows Start Menu, it comes up in the browser.

Page 1 of 1 (6 items)
Choose your language:  
powered by Communifire
Version 8.0.7757.16597