Loading ...

Virtual appliance PCNS 4.4 time is not correct - how to sync it? | UPS Management Devices & PowerChute Software

Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Virtual appliance PCNS 4.4 time is not correct - how to sync it?

Virtual appliance PCNS 4.4 time is not correct - how to sync it?

Discussion in UPS Management Devices & PowerChute Software started by Wojciech , 1/16/2021 4:16 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Announcement 

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

Posted in: General

Virtual appliance PCNS 4.4 time is not correct - how to sync it?

Subscribe to RSS
  • Hi All,

    I have PCNS 4.4 running as virtual appliance on VMware 5.5 host. Time reported by Centos (and used in PCNS in logs) is not correct. There is about 20 minutes difference to real time. Below you can see time settings reported by < timedatectl > command. Time zone is set correctly.

    How to sync time on Centos? Do I need to start NTP service? Or time for Centos is synchronized other way? How?

    BR

  • Hi Wojciech,

    Try the below command:

    sudo systemctl enable chronyd --now

    -Gavan

  • Hi Gavan,

    Thanks for your replay

    In the meantime, I was looking for an answer in a different direction, taking VMware Tools into account . One of the VMware Tools feature is synchronize time in VM guests. So I have followed alternative way described here: https://kb.vmware.com/s/article/1014038 , ie I ran <  vmware-toolbox-cmd timesync enable >  command inside VM guest

    Probably better way is :

    • Open the vSphere Client and connect to vCenter Server.
    • Right-click the virtual machine you deployed from OVF and click Edit Settings > Options > VMware Tools.
    • Under Advanced, select the Synchronize guest time with host option and click OK.

    As far I as know when VMware Tools is being used native operation system time sync should be disabled as it is replaced by VMware Tools functionality

    BR, Wojtek

     

     

     

  • PowerChute needs to be able to connect to the NMC Web Access port (default: ... The PowerChute virtual appliance should be used only for running the PowerChute pcnsconfig.ini to do this. If you enter “0”, PowerChute may not correctly identify Specify the length of time in seconds that the UPS Critical Event must.

     

  • Hi Sabala,

    Thanks for you replay.

    I have got filling that your replay do not refers to described problem

    I did not ask about setting time period length defined in Critical Event or any other event

    My question was about synchronizing Centos system time on which PCNS is running (and PCNS time) with VMware host time

    BR, Wojtek

  • Sorry I've been on annual leave, 

    The following commands should help:

    Show current time synchronization status:  sudo vmware-toolbox-cmd timesync status

    Disable virtual machine time synchronization:  sudo  vmware-toolbox-cmd timesync disable

    Enable virtual machine time synchronization:  sudo  vmware-toolbox-cmd timesync enable

    Restart Open VM Tools:  sudo systemctl restart open-vm-tools

    -Gavan

Page 1 of 1 (6 items)
Choose your language:  
powered by Communifire
Version 8.0.7732.32596