Loading ...

Unable to connect to PowerChute after upgrade from 9.5 to 10.0.1 | UPS Management Devices & PowerChute Software

Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Unable to connect to PowerChute after upgrade from 9.5 to 10.0.1

Unable to connect to PowerChute after upgrade from 9.5 to 10.0.1

Discussion in UPS Management Devices & PowerChute Software started by Ameet , 9/1/2020 8:07 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Announcement 

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

Posted in: General

Unable to connect to PowerChute after upgrade from 9.5 to 10.0.1

Subscribe to RSS
  • ameran

    Hi

    I've had a working installation of PowerChute 9.5 on a Windows 2012 R2 server connected to a SUA1500 via USB.

    After upgrading to PowerChute 10.0.1, I get a browser error: The site can't be reached. ERR_CONNECTION_REFUSED.

    I've tried Chrome & IE11, both don't connect. Also tried DNS Name, localhost and IP address, none of which connect.

    This was all working prior to the upgrade a few hours ago.

    Please advise.

    Thanks,

  • APC_Gavan

    Hi Ameet,

    Can you ensure that the powerchute service is started?

    If you press Start >> type "Services.msc" >> find the Powerchute services >> Right click and either press start or restart.

    -Gavan 

  • ameran

    Hi, 

    I've looked, there are no Powerchute services in the Services console.

    I've reinstalled & restarted to make sure the installation is complete, and it completes, but still not PowerChute in Services.

  • wpasquil

    Hi,

    Open a command prompt as an administrator and enter the command sc query apcpbeagent.

    The command should return what is below.

    If it returns the same then the service is running. If the service is not running enter the command net start apcpbeagent.

    If the service is running and you still cannot access the web page you should verify that the firewall rules have been applied to allow access to the web page. Go to the control panel, Windows Defender Firewall. Open the firewall rules and click on Advanced settings. Once in Advanced setting click on Inbound Rules. You should see PowerChute Business Edition Agent rules

    If the rules are not there you should click on New Rule and add the rules. You will need to add 2 rules. One for TCP and one for UDP. Set each to allow for all ports and they will need to point the path PowerChute was installed to. 

    If you do not want to add the Firewall manually, you can uninstall the PowerChute Agent, reinstall, and when asked allow the installer to edit the Firewall. The installer will add the needed rules. 

  • ameran

    Hi, 

    No luck!

    I removed the application, reinstalled 9.5 to make sure it was working, confirmed, can see the service.

    Then I proceeded to upgrade to 10.0.1, checked for the service, gone. Rebooted, still nothing.

    Revert to 9.5 and it works without issue.

  • wpasquil

    Hi,

    When you run the upgrade do these entries exist in the registry? 

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\APC\PowerChute Business Edition\agent
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\agent
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\agent
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\APCPBEAgent

    If they do would you please attach a copy of the pcbe.log file. Assuming you installed PCBE to the default path the file will be found in

    C:\Program Files (x86)\APC\PowerChute Business Edition\agent\log 

    Also, does PowerChute Agent version 10.0.1 run properly if you un-install version 9.5 and do a clean install of 10.0.1? 

Page 1 of 1 (6 items)
Choose your language:  
powered by Communifire
Version 8.0.7598.8416