Loading ...

PCNS 4.3 on RHEL 7.8 - web config inaccessible after install | UPS Management Devices & PowerChute Software

Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » PCNS 4.3 on RHEL 7.8 - web config inaccessible after install

PCNS 4.3 on RHEL 7.8 - web config inaccessible after install

Discussion in UPS Management Devices & PowerChute Software started by Theo , 5/12/2020 12:39 AM
Login to follow, share, and participate in this space.
Not a member?Join now
Announcement 

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

Posted in: General

PCNS 4.3 on RHEL 7.8 - web config inaccessible after install

Subscribe to RSS
  • vx_it

    Using PCNS 4.3 for Linux install files, on RHEL 7.8

    I'm running into a strange issue where I cannot access port 6547 for initial web setup even though the service is running. On this particular server, at least one other service is accessible (nginx on port 80). I have deployed PCNS to Linux before with no issues (mostly version 4.2 to older Linux OS). 

    Here is the output of my install. I've highlighted one error:

    Creating /opt/APC directory ...

    PCNS will be installed to /opt/APC/PowerChute

    Copying jre to /opt/APC/PowerChute ...

    Extracting jre to /opt/APC/PowerChute/jre ...

     

    openjdk version "11.0.1" 2018-10-16

    OpenJDK Runtime Environment 18.9 (build 11.0.1+13)

    OpenJDK 64-Bit Server VM 18.9 (build 11.0.1+13, mixed mode, sharing)

     

    JAVA_DIR=/opt/APC/PowerChute/jre-11.0.1/bin/

     

    Copying the installation files ...

    Extracting PCNS files ...

    PCNS is extracted to /opt/APC/PowerChute

    Configuring startup files ...

    Startup script=/usr/bin/PowerChute

    Installing Service ...

    Created symlink from /etc/systemd/system/default.target.wants/PowerChute.service to /etc/systemd/system/PowerChute.service.

    error reading information on service PowerChute: No such file or directory

    Configure Firewall

    Configuring firewalld

    Configuring uninstall script ...

    Setup the m11.cfg file

    Starting service ...

     

    Installation has completed.

    PowerChute Network Shutdown can be accessed through your browser at https://<your_server_ip_address>:6547

    Please complete the configuration wizard so that PowerChute Network Shutdown can protect your server.

    Here is the service status confirming it's running: 

    service PowerChute status

    Redirecting to /bin/systemctl status PowerChute.service

    ● PowerChute.service - PowerChute Network Shutdown

       Loaded: loaded (/etc/systemd/system/PowerChute.service; enabled; vendor preset: disabled)

       Active: active (running) since Fri 2020-05-08 18:04:56 PDT; 12min ago

      Process: 27332 ExecStart=/usr/bin/PowerChute start (code=exited, status=0/SUCCESS)

     Main PID: 27357 (java)

       CGroup: /system.slice/PowerChute.service

               └─27357 /opt/APC/PowerChute/jre-11.0.1/bin/java -Xrs -Xms32m -Xmx64m -Df...

    Here is an example of the page I get when attempting to load it. I've tried using http, https, hostname, FQDN, and IP:

    Any idea what could be causing it?

  • wpasquil

    Hi,

    To fix the link error login as root and create the link manually. First stop the PowerChute service (sudo service PowerChute stop) Then run the command sudo ln -s  /etc/systemd/system/PowerChute.service /etc/systemd/system/default.target.wants/PowerChute.service and finally restart the service (sudo service PowerChute start) 

    As for the web page, is the browser on the Redhat system or another system and what browser are you using? I ran a Google search and found a bunch of hit concerning that error when running Chrome. 

  • vx_it
    On 5/12/2020 8:05 AM, Bill said:

    Hi,

    To fix the link error login as root and create the link manually. First stop the PowerChute service (sudo service PowerChute stop) Then run the command sudo ln -s  /etc/systemd/system/PowerChute.service /etc/systemd/system/default.target.wants/PowerChute.service and finally restart the service (sudo service PowerChute start) 

    As for the web page, is the browser on the Redhat system or another system and what browser are you using? I ran a Google search and found a bunch of hit concerning that error when running Chrome. 

    Hi, when I run it I get the following error:

    [root@server ~]# sudo ln -s /etc/systemd/system/PowerChute.service /etc/systemd/system/default.target.wants/PowerChute.service
    ln: failed to create symbolic link ‘/etc/systemd/system/default.target.wants/PowerChute.service’: File exists

    The browser is on home PC - MS Edge. I've tried remotely on my work PC, and with Firefox as well. Same result.

Page 1 of 1 (3 items)
Choose your language:  
powered by Communifire
Version 7.0.7485.25369