Loading ...

| UPS Management Devices & PowerChute Software

Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Firmware upgrade for AP9631 which order?

Firmware upgrade for AP9631 which order?

Discussion in UPS Management Devices & PowerChute Software started by Coercion , 6/9/2014 5:30 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Announcement 

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

Posted in: General

Firmware upgrade for AP9631 which order?

Subscribe to RSS
  • Coercion

    Hi,

    Current verison for AOS and sumx for 5.1.3. And for bootmon is 1.0.1.

    I downloaded latest firmware for AP9631 and new versions are 6.1.1 and 1.0.2.

    I tried automatic method ( ...R2.exe) which gives me "Boot Monitor tranfer failed" error. So i thought i could go for ftp method.

    İ could ftp into the card. I have read that i should copy bootmon first then AOS then sumx.

    I have seen that older versions of AOS and sumx but there is no old bootmon file.

    Question is: Which order should i copy the files? Should i copy bootmon somewhere else or does it automatically move it somewhere else?

    Old versions of files would delete themselves when i copy new versions or should i delete them too?

  • ipicKedawinna

    Hello,

    Yes, you need to do bootmonitor, disconnect/exit FTP, the card will reboot and put the file in the right spot, do the AOS file, disconnect/exit FTP, and let the card reboot again, and lastly, put the sumx file, disconnect/exit FTP and the card will reboot one last time.

    The card accepts the file and manages the flash space automatically. You do not need to delete any files and the card does this automatically upon rebooting. Just upload/put files.

    Here are the instructions on manual upgrades (or any upgrade method) -> How do I upgrade the firmware on an APC Network Management Card? | FAQs | Schneider Electric US

    Let me know if you have any further questions.

    If the wizard does not work, then I'd make sure FTP is actually working. If the FTP data port is blocked, you can log in successfully but it hangs upon data transfer. I am wondering if that is why the wizard failed because it logged in but couldn't transfer the file. I had this problem myself before so if the FTP transfer doesn't work when you do it manually, you might need to pursue this. Or, maybe USB is an option.

    FYI - I consider this a "major" upgrade so I'd suggest reading this first -> Things To Consider When Upgrading or Downgrading a Network Management Card 2 (NMC2) Device between v5.X.X and v6.X.X | F…

  • Coercion

    I have read a lot of stuff before posting actually. I had looked at your links too.

    Like you said, ftp login is successful but when it tries to copy (i think) it gives me "550 STOR action not taken" error. Wizard also encounters this error i think. Web says it is related write permissions.

    I got 10pin ethernet to usb cable comes with ups itself. What kind of cable do i need to try other methods?

    Which side of the ftp data port is blocked? Is it related to my windows 7 computer or my AP9631. I tried shutting down Windows firewall, running in administrator mode, still same error

  • ipicKedawinna

    What do you mean "web says its related to write permissions" - I assume you mean by researching online the "550 STOR action not taken" and not anything in the AP9631 interface?

    I do think the FTP data port is blocked on your computer's end. There is no way to block it on the AP9631 side. In my personal experience with this, my Cisco VPN service was blocking this port, even though I was not actively connected to the VPN. You may want to try another computer perhaps if you cannot pinpoint what could potentially be blocking this.

    In order to try different methods, you can do the USB as I noted, or XMODEM will require a direct connection with the 940-0299 DB-9 to 2.5mm Tip Ring Sleeve (TRS) cable that comes with the AP9631 and connects to the little jack labeled "console" on the AP9631. (The cable looks like it has a mono headphone jack on one end). You'd then follow the XMODEM instructions in the article I linked that requires you to access BootMonitor @ 57600 baud rate. You cannot use the cable that came with the UPS in doing this.

    The easier option might be USB if you have local access to the card. Just make sure your USB drive is formatted as FAT file system as noted in the knowledge base.

  • Coercion

    I meant i googled 550 STOR error, correct.

    You must using a Cisco cable modem/router. I'm using:

    Cisco Modem > Pfsense Router > 2 Cisco 200 series smart switches connected to each other(backbone of my home network). These switches contains aggrevated links and vlans. Connecting to work's ftp servers doesn't cause any problems. Maybe inside the network there could be some limitations due to complexity, ill check that.

    I just noticed the usb method could be used for my NMC. I'll try that first.

    I dont have that direct connection cable. I think that's because i bought this card as "opened box" condition. Even though all papers are present and packaging is original, there were no cables.

    I'll write how it went

  • ipicKedawinna

    Hello,

    OK. And no, I meant internally, we had used Cisco VPN client in the past. This software program on my computer running in the background was blocking the FTP data port, even though I did not have an active VPN connection. So whether I was at home, behind a standard wireless router connected via VPN or not, or within the corporate network at the office directly connected to our network, the VPN service was running in the background blocking it via the service's stateful packet inspection firewall.

    Hopefully USB will work and take less time so that long term, perhaps you could figure out what is going on with FTP to the card.

  • Coercion
    This discussion is marked as answered

    Ok i finally solved all the problems and upgraded the firmware.

    I'll write some of the issues i encountered for other people

    1. I was assuming default username:password combination was "device:apc" all along. While this is correct it is not root or admin account, correct combination should be "apc:apc". "device" username has limited access and it doesnt have write permissions. I comfirmed that after firmware update. I think that's why all scp, ftp, auto update features were failing

    2. The document says some usb drives are not compatible. I first tried a USB3 stick which didnt worked. I switched to USB2 drive to complete the job

    Now, i think my problem was using wrong username and password smile

  • ipicKedawinna

    Thanks for sharing what you've found. Perhaps a poor assumption on my part that you were using the administrator account embarassed but yes you're right, you cannot use the device or read only permission levels or accounts to upgrade firmware or do an FTP connection. I will remember to verify that in the future with other users and not assume.

    I know our USB on the NMC is 1.1 - does your USB 3.0 drive support 1.1 or just 2.0 and 3.0?

    Glad you got everything upgraded though too.

  • Coercion

    İ checked manufacturer's site for thumb drive, it says "Compatibility: USB 3.0 and USB 2.0". I think that means no USB1.1 so no compatibility?

  • ipicKedawinna

    Hmm, guess not. Thanks for checking.

Page 1 of 1 (10 items)
Choose your language:  
powered by Communifire
Version 8.0.7598.8416