Loading ...

E-mail notifications - not working | UPS Management Devices & PowerChute Software

Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » E-mail notifications - not working

E-mail notifications - not working

Discussion in UPS Management Devices & PowerChute Software started by David , 3/5/2017 9:47 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Announcement 

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

Posted in: General

E-mail notifications - not working

Subscribe to RSS
  • dma999999

    Hi there. I have a Smart-UPS X 3000 with a Network Management Card 2. It's configured using DHCP and I've tested the DNS and it works just fine.

    I am however having a bit of trouble configuring e-mail notifications for some reason. I have input an external e-mail server with the address: smtp.[isp].com, port 25. This is the server that must be used as my ISP blocks port 25 except for its server. It requires no authentication and no encryption, and I've set the settings on the UPS accordingly. On my local network, I have a Sophos XG firewall which intercepts, scans, and then forwards e-mail.

    When I try sending a test e-mail, I get this message in the web interface:

    Last Test Result
    ([recipient email address) Test e-mail failed; SMTP configuration error.
    Last Server Response
    354
    The event log isn't all that helpful:
    System Email: Could not mail 'smtp.[isp].com'. 0x001A
    For the various other devices I have which send e-mail in the same manner, the logs of my firewall show the e-mail being accepted, scanned and then forwarded on. However, with the UPS, nothing ever shows up.
    I suppose the other odd part about this is the "Last Server Response". From what I understand 354 is just a code from the receiving server for the sender to start transmitting the mail, and is not an error message.
    I have a few other APC devices with network management cards and have no problem at all having them send e-mail alerts with the exact same settings as I've tried for the UPS, and they all work just fine. It's only the UPS that seems to be challenging. 
    I'm at a bit of a loss in trying to figure out how to even diagnose the problem. Any suggestions would be most appreciated.
  • vinay

    Hi David,

    Can you share the config.ini of this card and also the config.ini file of the cards on which email is working. I need to check if there is any changes in the email settings. If you have identical working card with 6.x.x firmware on it then you can try uploading the config.ini file of a working card to the non working, so that both have the same settings. Here is the knowledge base article on how to retrieve the logs and config.ini file from the card.

    Link: http://www.apc.com/us/en/faqs/index?page=content&id=FA156131&actp=search&viewlocale=en_US&searchid=1488813265270#__highlight

    The path to upload the config.ini to the non working card is below

    From NMC web gui click on Configuration-->General-->User config file

  • dma999999

    Thank you very much for the suggestion. I'd very much prefer not to overwrite the config.ini on the device that's not working, as there are various other settings in that file that are specific to each device. FWIW I checked all the e-mail settings and they all appear to be consistent between the working device and the non-working device.

    Happy to share both files but would perhaps prefer not posting them - will see if I can figure out how to DM to you.

  • dma999999

    Sorry - I can't seem to figure out how to send you a private note. Is there a way to do so? When I try clicking on your profile it indicates that it's private...

  • vinay

    Hey David,

    Please send the files to my email address: vinay.gopinath@schneider-electric.com

  • dma999999

    Thanks very much. I've sent over the config files.

    Just in case others are looking at this thread, I should have also mentioned originally that the other APC devices on which the e-mail notification works are all older NMC1 devices, while the one I'm having trouble with is NMC2.

  • vinay

    Thank you for the config.ini. The only difference I can see in both config.ini is the DNS configuration. Can you confirm whether the DNS primary IP which you have set is a valid one? As a troubleshooting can you try entering the IP address of the SMTP server instead of domain name in SMTP server field and also change the from address to user@[IP_address] if Local SMTP Server is specified as an IP address

  • dma999999

    Thanks for the note. I had previously played around with the DNS settings on the UPS (the device that isn't sending e-mail). I set it to my internal DNS, and then to an external DNS (that of my ISP). Unfortunately it didn't make a difference. The primary DNS shown in the config file I sent to you was the internal DNS server, which I confirm is valid and has been tested.

    I tried entering the IP address of the SMTP server and changed the from address as you suggested. When I try a test e-mail I don't get any error message, but it just continues saying "E-mail test in progress.". I've tried this twice waiting about 5 min for an update.

    For what it's worth I also tried changing the server in the recipient list from "Local" to "Recipient" (after changing back the e-mail server to the domain name). Same result - just keeps saying "E-mail test in progress."

    I'm not sure if this is relevant, but is it possible there is a bug in the e-mail code for the UPS? As originally noted, the UPS returns "Last Server Response: 354" when saying it has encountered an SMTP configuration error. When I googled this, one of the results I found indicated the following:

    As you see, the code 354 means "OK, we're done with the information about sender and recipient, now give me the actual mail". However, your webmail system has been coded to think that only response codes starting with a 2 means "succeeded", so it takes any other code to mean that there's a problem. Whoever wrote the webmail program needs to go back and read RFC 5321 again and then fix the bug.

    Any further thoughts you may have would be most appreciated.

    Thanks.

  • B-DoubleE
    On 3/7/2017 7:36 AM, David said:

    Just in case others are looking at this thread, I should have also mentioned originally that the other APC devices on which the e-mail notification works are all older NMC1 devices, while the one I'm having trouble with is NMC2.

    The major difference between email support on NMC1 vs NMC2 is authentication/encryption support - NMC1 does not support any email authentication. On the NMC2 cards, is it possible that the cards are configured to use TLS to connect to the SMTP server? 

  • dma999999
    On 3/10/2017 8:45 AM, Matt said:

    is it possible that the cards are configured to use TLS to connect to the SMTP server? 

    Thanks Matt. Both authentication and encryption are turned off on the UPS with the e-mail issues.

  • rondal

    Hi, I have exactly the same problem. Was your problem ever solved? What did you do?

    Thanks Roland

  • dma999999

    It has been a while but I believe things started working after I upgraded to the 6.5.0 firmware for the Network Management Card 2. If you're on an earlier version you might want to give that a try if you haven't already. Hope that might be of some help.

  • rondal

    Wow. Thanks. After updating to version 6.7.2 it works. But shame on me. Only because of your email I found out that the Network Management Card has its own firmware.

    Best Roland

Page 1 of 1 (13 items)
Choose your language:  
powered by Communifire
Version 6.0.7207.29305