Loading ...
Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Test e-mail failed; SMTP configuration error sporadic with gmail account

Test e-mail failed; SMTP configuration error sporadic with gmail account

Discussion in UPS Management Devices & PowerChute Software started by Michael , 6/16/2016 4:57 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Announcement 

Please review Schneider Electric Knowledge Base articles for assistance with most technical support questions.  http://www.apc.com/us/en/faqs

  • porter224
    Michael
    Novice Novice
    Michael 6/16/2016 4:57 PM

    I have the correct information for the email and addresses within the software with the AP9631 .  When I run a test 95% of the time it fails, the other 5% of the time it works.  I ran a test SMTP software from my laptop and passes with flying colors.  

    I have attached the config file for your enjoyment.  

    Anyone else who uses gmail have these issues at all?

    Attachments
  • ipicKedawinna
    Angela
    =S= Representative
    Angela 6/16/2016 5:40 PM (in response to Michael)

    Hi Michael,

    I see by the config.ini, you're a few firmware versions behind. I am not necessarily saying it will fix the issue you're seeing specifically but I have been using Gmail with it with no issues. But, I have tried Gmail on the version you have too and don't recall having any issues there either. All the issues we do see are related to something else - network access/config, firewall, DNS, Gmail account configuration, etc.

    Here is a knowledge base we have that you can check for when configuring services like Gmail or Google Apps: http://www.schneider-electric.us/en/faqs/FA164769 

    We put all the stuff we know in that article that comes up as well like making sure security settings on Gmail are set properly.

    I'd also check your event log at the time of the email failures and look to see if there is anything else happening such as DNS errors perhaps. I can look at that file too if you post it like you did the config.ini.

    Here is the newest firmware you can try if you want. It also has many security updates which I'd recommend to any user and is our latest code: ftp://restrict:Kop$74!@ftp.apcc.com/restricted/hardware/nmcard/firmware/sumx/640/apc_hw05_aos640_sumx640_bootmon108_v4.exe and instructions to apply if you need them: http://www.schneider-electric.us/en/faqs/FA156047

    I didn't see anything strange in your settings either. 

  • porter224
    Michael
    Novice Novice
    Michael 6/16/2016 6:10 PM (in response to Angela)

    Thank you!  I appreciate your response.  I updated the firmware but still continue to get the same issue.  I get Test e-mail failed; SMTP configuration error.  I am bot getting any response from the server  

    How would I check my error logs?  Could you tell me how to download the file as well?

  • ipicKedawinna
    Angela
    =S= Representative
    Angela 6/16/2016 6:36 PM (in response to Michael)

    Hi Michael,

    Sure. To make it easy, just grab me the .tar file as explained here (http://www.schneider-electric.us/en/faqs/FA156131) and it has everything I'd every need. 

    If you're in the web, you can go to About menu->Support. Press generate logs then download logs and when its done. (That is the short version of what the kbase says.)

    I'll see if I see anything in the logs and go from there. One thought I had though was to try a DNS test which is under Configuration->Network->DNS->Test in the web and type in smtp.gmail.com and query type of by FQDN and see if you see anything. You can try now or after I check the logs for you.

  • porter224
    Michael
    Novice Novice
    Michael 6/16/2016 9:10 PM (in response to Angela)

    I ran the smtp.gmail.com DNS test and it ran fine.  

    I have attached the.tar file for you!

    Thank you for all your help!!

  • ipicKedawinna
    Angela
    =S= Representative
    Angela 6/17/2016 3:11 PM (in response to Michael)

    Hi Michael,

    I took a look at the logs and config. It seems to had configured both the local email server and the custom option. Which one are you actively trying? I prefer the custom setting if you will only have one recipient. This just allows you to configure individual servers for each recipient. I especially like it because recipient and email server configuration are both on the same screen.

    If you're using the custom option, I didn't see the correct port and authentication modes set - the 587 and the Optional SSL/TLS authentication. They seemed accurate in your previous config - were you trying different options and playing around?

    I ask because the event log has some of these: 

    06/16/2016 11:00:33 System Email: Could not mail 'blueacorn.com'. 0x001A
    06/16/2016 12:54:05 System Email: Could not mail 'smtp.gmail.com'. 0x001A
    06/16/2016 12:53:32 System Email: Could not mail 'smtp.gmail.com'. 0x001A
    06/16/2016 12:52:59 System Email: Could not mail 'smtp.gmail.com'. 0x001A
    06/16/2016 12:52:25 System Email: Could not mail 'smtp.gmail.com'. 0x001A

    What usually works for me is set the recipient to use custom mail server. Use smtp.gmail.com like you were, port 587, and its either implicit or always authentication mode. I think it might actually be implicit.. Then, for your authentication credentials use your email address and log in credentials. In some instances too, the "from" address you use must match your email address. You could try testing like that as well instead of setting the from address as "upspoweralerts@xxxxxxx.com." Lastly, make sure that "allow unsecure apps to connect" is enabled in your email account. I assume it is if you get periodic emails.

    The messages in the event log to me, assuming all of the settings are accurate as I noted, would indicate a DNS or network connection issue. I usually think DNS first. Can you try multiple DNS tests for different things and see if it fails like the SMTP does - like only works part of the time? That was another thing I think I'd try if I were there.

  • porter224
    Michael
    Novice Novice
    Michael 6/17/2016 3:30 PM (in response to Angela)

    Thank you, Angela!  I have changed the reset the option and changed to just the custom option.  I have attached the .tar so you could see it again. 

    The Webcard is on a IP that is not blocked by a firewall.  I have checked the DNS and tested and had no issues.

    I am having issue with both of the cards.  It must be something that I am doing.   

  • ipicKedawinna
    Angela
    =S= Representative
    Angela 6/17/2016 3:59 PM (in response to Michael)

    Did you try making both the recipient's address and from address the same? I see you're using upspower alerts and michael.xxxxx. 

    I also saw in your log that you had configured an SMTP SSL cert at some point - was this on purpose? I have seen another Google Apps user have to use this. Not sure if you were given any specific instructions by Google on this topic.

    Do you have a regular Gmail (non Google Apps)  or even another similar type of email provider account to try with and see if it acts any differently?

  • porter224
    Michael
    Novice Novice
    Michael 6/17/2016 4:28 PM (in response to Angela)

    Hey Angela!

    Yeah I was try all sorts of things to get it to work.  Just getting frustarted.  I tried both of them and it is not working.  I tried with my personal account and it is not working here is the .tar.  BTW, thank you for all your help!!

  • Page 1 of 1 (9 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692