Loading ...

AP8959EU3 bricked?! | Racks, Rack Accessories, & Cooling

Home » Spaces » Racks, Rack Accessories, & Cooling » discussion » General » AP8959EU3 bricked?!

AP8959EU3 bricked?!

Discussion in Racks, Rack Accessories, & Cooling started by Rene , 5/19/2019 7:38 AM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

AP8959EU3 bricked?!

Subscribe to RSS
  • Rene

    Hey guys,

    I'm getting more and more frustrated by the minute. Yesterday I had a maintenance window in our office to patch all APC/Schneider Electric PDUs to their latest respective firmware. I had already done this with our main server rack pdus so I was confident that everything will work just fine.

    But I was about to get disappointed really quick. Reason for that was, that the first pdu I tried to upgrade failed (because the password was longer than 11 characters -> hadn't read this KB article careful enough https://www.apc.com/us/en/faqs/FA156047 ).

    But I could fix that be rebooting the NMC, changing the password and running the upgrade tool again.

    Next I wanted to upgrade all six of our AP8959EU3 main server rack pdus.

    I knew that they usually fail with the "OS" transfer with the first run, so I was prepared for that. On the first run 5/6 pdus had an "error". Exactly like I anticipated after transferring the OS and before loading the application. So I removed the successful pdu from the iplist and went on with the second run of the upgrade tool.

    This time 4/5 pdus were upgraded successfully but the one with the error got my attention right away. Cause this time the upgrade tool showed an error while transferring the boot monitor. That was weird. That file was already transferred successfully in the first run.

    I logged into the pdu via telnet (don't ask me why were are still using this ancient crap instead of ssh!) without any issues and this is was "about" shows me:

    apc>about
    E000: Success
    Hardware Factory
    ---------------
    Model Number: AP8959EU3
    Serial Number: ZA1525026994
    Hardware Revision: 02
    Manufacture Date: 06/22/2015
    MAC Address: 00 C0 B7 EB FC 6B
    Management Uptime: 0 Days 0 Hours 9 Minutes

    Network Management Card
    ---------------
    Model Number: AP9537
    Serial Number: ZA1525084457
    Hardware Revision: 05
    Manufacture Date: 06/20/2015

    Application Module
    ---------------
    Name:
    Version: v..
    Date:
    Time:

    APC OS(AOS)
    ---------------
    Name: aos
    Version: v6.4.0
    Date: Dec 18 2015
    Time: 15:04:27

    APC Boot Monitor
    ---------------
    Name: bootmon
    Version: v1.0.8
    Date: Apr 8 2014
    Time: 10:59:40

    I tried the upgrade tool a couple of times but always with the same result. I got stuck while transferring the boot monitor.

    So I tried to transfer the files myself via FTP (I used the built in ftp client in Windows 10 command line as well as WinSCP) and tried to transfer all files. Boot monitor, aos, and application. All transfers get aborted after I have transfered a couple of bytes.

    After that I tried the usb method. I plugged in the prepped fat32 formated 8GB usb stick with the folder "apcfirm" including the three .bin files as well as the upload.rcf file.

    BM=apc_hw05_bootmon_108.bin
    AOS=apc_hw05_aos_672.bin
    APP=apc_hw05_rpdu2g_672.bin

    After I plugged it in, I pressed the reset button and released it immediately (rebooting the NMC instead of resetting it). Now the NMC isn't reachable via network anymore and first the amber LED starts blinking and shortly after that the green led on the network port. Due to a light on the thumbdrive I can see that it is accessed.

    But that cycle of LED blinking and read access of the usb thumbdrive doesn't stop. I waited about 30min without any change of behaviour.

    After that I tried connecting to the pdu via the console cable. I used the serial to console port cable that came with the unit and used a serial to usb converter to attatch all of that to my laptop. But sadly I can't read anything from the console by the looks of it. But that is true for ALL pdus that I tried to connect to.

    So long story short: Can someone tell me how to "unbrick" my pdu so that I can finally access the webinterface again?

    Thanks in advance.
    René

     

    P.S. Yes I also have seen this article here: https://www.apc.com/us/en/faqs/FA293874/ but nonetheless I used TeraTerm and the cable 940-0144A (and two different Serial to USB cables!) I don't see any output on the Terminal window. :-/

  • Rene

    On my last attempt, I was finally able to get into the bootmonitor by basically holding the <enter> key pressed *before* I rebooted the NMC.

    Trying to send the files to the NMC now. I'll keep you updated...

  • Rene

    Hi,

    I'm able to transfer data via the painfully slow xmodem connection. But whenever I do that (regardless of which file I use and with which file I start), I always get the following message at the end of it:

     

    BM>xmodemC

    Rhodes BootMonitor

    XModem Failure (Invalid Signature)

    What am I doing wrong? I tried with firmware 6.6.4 as well as 6.7.2 (and I'm about to test 6.5.6). I wanted to try and use 6.4.0 but I can't find it anywhere to download. :-/

Page 1 of 1 (3 items)
Choose your language:  
powered by Communifire
Version 6.0.7119.9640