Loading ...

8941 webUI issue | Racks, Rack Accessories, & Cooling

8941 webUI issue

Discussion in Racks, Rack Accessories, & Cooling started by Allan , 9/24/2018 2:47 AM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

8941 webUI issue

Subscribe to RSS
  • allan.capel

    Hi All,

    Newbie here- I upgraded an 8941 to 6.5.6 and have the following error on the webUI:

    "The application you are trying to load is incompatible with the current APC OS. Please verify the correct firmware is loaded."

    I can ping/ftp/telnet to it with no issues. Here's the required info - I think... that I need:

    Schneider Electric                      Network Management Card AOS      v6.5.6
    (c) Copyright 2018 All Rights Reserved  RPDU 2g APP                      v6.5.6
    -------------------------------------------------------------------------------
    Name      : apc865400                                 Date : 09/23/2018
    Contact   : Unknown                                   Time : 14:03:52
    Location  : Unknown                                   User : Super User
    Up Time   : 2 Days 7 Hours 49 Minutes                 Stat : P+ N4+ N6+ A!
    Type ? for command listing
    Use tcpip command for IP address(-i), subnet(-s), and gateway(-g)
    apc>system
    E000: Success
    Host Name Sync: Disabled
    Name:           apc865400
    Contact:        Unknown
    Location:       Unknown
    Message:
    DateTime:       09/23/2018:14:03:56
    User:           apc
    Up Time:        2 Days 7 Hours 49 Minutes
    Stat:           P+ N4+ N6+ A!
    Bootmon:        bootmon:v1.0.8
    AOS:            aos:v6.5.6
    App:            rpdu2g:v6.5.6
    apc>about
    E000: Success
    Hardware Factory
    ---------------
    Model Number:           AP8941
    Serial Number:          5A1423E05606
    Hardware Revision:      02
    Manufacture Date:       06/07/2014
    MAC Address:            00 C0 B7 86 54 00
    Management Uptime:      2 Days 7 Hours 49 Minutes
    Network Management Card
    ---------------
    Model Number:           AP9537
    Serial Number:          5A1423E02009
    Hardware Revision:      05
    Manufacture Date:       06/07/2014
    Application Module
    ---------------
    Name:                   rpdu2g
    Version:                v6.5.6
    Date:                   Apr 24 2018
    Time:                   11:42:41
    APC OS(AOS)
    ---------------
    Name:                   aos
    Version:                v6.5.6
    Date:                   Mar 30 2018
    Time:                   16:51:08
    APC Boot Monitor
    ---------------
    Name:                   bootmon
    Version:                v1.0.8
    Date:                   Apr  8 2014
    Time:                   10:59:40
    apc>dir
    E000: Success
         3058944 Mar 30 16:51  apc_hw05_aos_656.bin
         2678276 Apr 24 11:42  apc_hw05_rpdu2g_656.bin
           45000 Sep 23 14:04  config.ini
               0 Jun  7  2014  db/
               0 Jun  7  2014  ssl/
               0 Jun  7  2014  ssh/
               0 Jun  7  2014  logs/
               0 Jun  7  2014  sec/
               0 Jun  7  2014  dbg/
               0 Jun  7  2014  fwl/
               0 Jun  7  2014  email/
               0 Jun  7  2014  lang/
               0 Jun  7  2014  pdu/
               0 Jun  7  2014  rms/

    I'm thinking that I uploaded the wrong firmware and want to correct this. I'm having trouble finding the appropriate information to correct the issue. Any assistance would be greatly appreciated!

    Thank you
    Allan
  • s.v.s

    Hi Allan,

    The Stat section of the control console (A!) indicates that the application module of the firmware is not compatible with the AOS. On the other hand, SFRPDU2G656 (AP8xxx; AP7xxxB Series Rack Power Distribution Unit Firmware Revision 6.5.6) is the appropriate firmware for the AP8941. There's a chance the application failed to load - you can issue a reboot command from the console, this will cause the application to attempt to reload. If the behavior persists after reboot, reflashing the PDU firmware should restore it to normal behavior.

    For convenience, I'll include the link to the firmware file as well as the knowledge base article that covers a couple of upgrade methods.

  • allan.capel

    Hi Szabi,

    I ran the reboot command, didnt fix, and then ran the firmware update based on the link you provided. It successfully upgraded the firmware but did not rectify the issue with the webUI.

    Starting Upgrade 09/24/18 16:42:27 
    -----------------
    [09/24/18 16:42:27] 10.2.2.172: Pinging (via ICMP) device
    [09/24/18 16:42:27] 10.2.2.172: Device connection passed
    [09/24/18 16:42:28] 10.2.2.172: Testing FTP Log-in
    [09/24/18 16:42:31] 10.2.2.172: FTP Log-in passed
    [09/24/18 16:42:32] 10.2.2.172: Saving data file
    [09/24/18 16:42:33] 10.2.2.172: Information --> Unable to verify previous version 
    [09/24/18 16:42:33] 10.2.2.172: Saving event & configuration files
    [09/24/18 16:42:33] 10.2.2.172: Transferring firmware file (1/3): Boot Monitor
    [09/24/18 16:42:40] 10.2.2.172: Boot Monitor transfer successful
    [09/24/18 16:42:42] 10.2.2.172: Restarting network interface
    [09/24/18 16:43:34] 10.2.2.172: Device connection passed
    [09/24/18 16:43:36] 10.2.2.172: Testing FTP Log-in
    [09/24/18 16:43:36] 10.2.2.172: FTP Log-in passed
    [09/24/18 16:43:37] 10.2.2.172: Transferring firmware file (2/3): OS
    [09/24/18 16:44:25] 10.2.2.172: OS transfer successful
    [09/24/18 16:44:27] 10.2.2.172: Restarting network interface
    [09/24/18 16:44:47] 10.2.2.172: Pinging (via ICMP) device
    [09/24/18 16:45:20] 10.2.2.172: Device connection passed
    [09/24/18 16:45:22] 10.2.2.172: Testing FTP Log-in
    [09/24/18 16:45:23] 10.2.2.172: FTP Log-in successful
    [09/24/18 16:45:24] 10.2.2.172: Transferring firmware file (3/3): application
    [09/24/18 16:46:08] 10.2.2.172: Restarting network interface
    [09/24/18 16:46:18] 10.2.2.172: Pinging (via ICMP) device
    [09/24/18 16:51:41] 10.2.2.172: No language pack selected
    [09/24/18 16:51:41] 10.2.2.172: OS & Application transfer completed



    Do you have any recommended next steps? I think I upgraded from 3.7.3 - can I downgrade to that? I have other PDU's running that version. I haven't been able to pull the firmware off an existing PDU via ftp though. 

    Thank you for any assistance you can offer.
    Allan

  • ipicKedawinna
    On 9/24/2018 4:54 PM, Allan said:

    I think I upgraded from 3.7.3 - can I downgrade to that? I have other PDU's running that version. I haven't been able to pull the firmware off an existing PDU via ftp though. 

    Hi Allan,

    FYI, the 3.X.X firmware versions for PDU are only used with the AP7XXX series models. This model (AP8941) would've never worked with that so you may just have other older models using this.

    Question on the original issue - did this happen after you did anything specific - like configure email notifications or some other piece of configuration? What you're describing to me indicates maybe there is something going on here sending the PDU into a reboot loop and it stops after 6 attempts by design since the app won't load properly which then displays the message you're seeing in the web UI. If you did the reboot Szabi suggested, did you happen to be near the unit and observe if it was continually rebooting?

    My first thought here is to potentially reset the PDU to defaults (keep TCP/IP settings option) or if you can afford to lost remote access and the IP address and reconfigure, to "format" it an wipe EVERYTHING. Then, observe if PDU is acting normally. This would potentially get rid of any corruption in the configuration if that is the case here. We can slowly reconfigure it to observe if it is a certain piece of configuration causing this to happen. I am not sure if you have a backup config.ini file as well and can afford to do any of this but it is how I would proceed considering the circumstances.

    Of course, before proceeding, let me know if this makes sense or if you have any questions.

    More info - to reset to defaults or format, we can issue one of two commands through CLI. Alternatively, to "format" specifically, you can press and hold the pinhole reset button on the PDU display itself. You press and hold for 20 seconds or so and the status LED pulses green. When it changes to amber, you let go and the process completes. Again, format function is optimal but it will wipe the TCP/IP settings. If you cannot afford that, we should try reset to defaults with the keep IP option.

Page 1 of 1 (4 items)
Choose your language:  
powered by Communifire
Version 6.0.7207.29305