Loading ...

| Racks, Rack Accessories, & Cooling

AP7922 Firmware

Discussion in Racks, Rack Accessories, & Cooling started by Rob , 5/8/2017 5:50 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

AP7922 Firmware

Subscribe to RSS
  • Daemonic


    We have not been using out AP7922 for some time now, and we are starting to use it again. I realise the the product was discontinued in January 2017, but i would like to get the latest firmware for it if at all possible. Does anyone have a copy of it available?


  • ipicKedawinna

    Hi Rob,

    You can get it here: ftp://restrict:Kop$74!@ftp.apcc.com/restricted/hardware/nmcard/firmware/rpdu/392/apc_hw02_aos392_rpdu392.exe

    If you need instructions on how to upgrade: http://www.apc.com/us/en/faqs/FA156047

  • apc005

    Unfortunately this link is invalid and the download link in the product page http://www.apc.com/shop/us/en/products/Rack-PDU-Switched-1U-16A-208-230V-8-C13/P-AP7921?isCurrentSite=true does not work too :-((((((

  • michaelr

    The support from APC is extremely poor on this. I've managed to find the file on the web somewhere (although I would prefer downloading it from the APC website itself), see attachment. 

    Upgrading the device was also a pain. Using the provided tool doesn't work as it takes a long time for the tool to verify the current version and then after uploading has started it ends with an unknown failure. Uploading the files through FTP was also not working as it also gave errors during transfer.

    I ended up with SCP'ing the files to the devices. For this you first have to enable SSH v2 via the webinterface and then upload first upload "apc_hw02_aos_392.bin". After upload (which takes about 5 minutes per file) is finished the devices reboots automatically after a few seconds. When it returns the webinterface is not working and is reporting an problem (this is normal). Then wait a few minutes (SSH is not working directly afterwards) and upload the second file "apc_hw02_rpdu_392.bin" and wait for the unit to reboot again. Afterwards you should be at 3.9.2. for both rpdu and AOS.

    Please APC provide better service!

  • Terry_Kennedy

    I agree (just as another APC customer) that their main website is just plain awful, and is even less functional than the previous version (which didn't look great, but worked). It appears that they got someone to "design" it, rather than make it work. Oh well, perhaps it will win a design award. I believe the APC folks here are well aware of this, but aren't anywhere near the people responsible for the web site.

    In any event, this link should get you to an APC page with a "download" button that will take you directly to the correct download.

    Or this link which should drop you into the parent directory for all firmware. Depending on your browser, it may or may not work. On Internet Explorer 11, you have to right-click and select "go copied address" from the menu for it to work. This URL has worked for well over 10 years now and I don't expect it to change, no matter how they mangle the main web site. Note that you are responsible for picking the correct file for your particular device - neither APC nor I can be responsible if you download and install the wrong file because you went directly instead of via APC's official links.

  • michaelr

    The first link does not include firmware for the AP7723. The second one has no link attached to it.

    The responsibility of APC should be to provide good access to the firmware. That way customers don't have to download it from unknown websites.

Page 1 of 1 (6 items)
Choose your language:  
powered by Communifire
Version 7.0.7446.33821