Loading ...

| Racks, Rack Accessories, & Cooling

AP7900

Discussion in Racks, Rack Accessories, & Cooling started by Rebekah , 12/13/2016 8:45 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General
  • rhayes

    Is the 3.92 firmware not valid for AP7900?  We've gone so far as to factory default on of the pdu's but the upgrade fails each time.  If this is not valid where can the 3.74 firmware be found?

    Thanks

  • ipicKedawinna

    Hi Rebekah,

    Yes, there is an AOS 3.9.2/rpdu application 3.9.2 for AP7900. The file would be apc_hw02_aos392_rpdu392.exe that you would've downloaded.

    Can you elaborate on the issue you're seeing? Is the firmware not upgrading properly? Just let me know what you've tried so far specifically and the current state the unit is in and we can hopefully figure this out.

  • rhayes

    Loading OS, please wait ... Firmware download failed.  This happens on multiple units.  I've attached a screenshot.

    Attachments
  • rhayes

    Sorry I didn't really answer all of your questions.  We have approximately 10 of these units.  We tried using the utility apc_hw02_aos392_rpdu392.exe and it always fails at the same point (see attachment to previous post).  I believe 5 units were tried.  At some point during troubleshooting, two of the units were factory defaulted.  Seems to have made no difference.  He also tried straight ftp on of the units.  It is now accessible only by ftp and only shows the aos374.bin and I assume I need to find the rpdu374.bin to make that pdu accessible again.

  • ipicKedawinna

    Hi Rebekah,

    No problem, thanks for elaborating.

    We have two things we can try based on what you've told me...

    1.) Try manual FTP and loading AOS 3.9.2 on, the PDU will restart its management interface which then you reconnect and transfer rpdu application file 3.9.2. It is possible there is a problem using the .exe and the timing of the tool is not working properly for your network or environment for some reason. Hard to tell but that is what I suspect. Alternatively, the FTP data port could be blocked - where FTP log in will work but no data transfer. You'll be able to see this more clearly if you do manual FTP to confirm it where when you attempt to transfer the file, it times out. 

    Here are the manual FTP instructions - follow them for NMC1 -> http://www.apc.com/us/en/faqs/FA156047 .. make sure to do the hash command to show ### for your progress. If you try to push the new AOS and no ### are displayed, this likely indicates the blocked FTP data port problem.

    The reason why the PDU is no longer is accessible is because in order to accept the new AOS file, the app is deleted to make room. After the file is transferred during a typical upgrade, the network management interface reboots and loads the app into the AOS space of the flash memory. So, the process sort of started in your case but didn't finish because seemingly the new AOS file is not being transferred over fully or correctly.

    2.) Depending on what you find above, you can try loading the rpdu 3.7.4 bin file but if FTP data port is blocked, this won't work either. I'll attach the .bin to this post just incase.

    Let me know how that goes.

    Attachments
  • rhayes

    I'm halfway through and it's worked perfectly on every one I've tried.  Thanks for your help.

  • ipicKedawinna

    Which one - the new AOS 3.9.2/rpdu 3.9.2 via FTP or putting the 3.7.4 back on?

  • rhayes

    3.9.2

  • packetman

    On a separate note -- and please forgive me if I just haven't found that information in the forum yet -- but are there any known issues with the 3.9.2 firmware on the AP7801 hardware?  After an upgrade, HTTP/HTTPS seems to be unavailable, and SSH is unreliable.

  • ipicKedawinna

    Hi Craig - no, there are no known issues like that which we are aware of. We'd have to check into specific details on what your AP7801 is exhibiting. The only thing that comes to mind is that that firmware still only supports TLS 1.0 so HTTPS access could be blocked by your web browser. Same with the SSH server being older and perhaps blocked by certain clients. We are releasing AP7801B which is the same PDU with an upgraded management interface. For existing customers like yourself, we are trying to make TLS1.1 and 1.2 work on the existing hardware but it is not as easy as it sounds with the older management interface. Same with modifying SSH and which cipher suites it supports. 

    Lastly, depending on how you have things configured and what other protocols your running with these two (SNMPv3 for example), things could get a bit slow in general. 

  • abubienczyk

    Hi Angela!

    I am looking for the firmware.

    Can you direct me where I can download it?

    Please let me know.

     

  • wpasquil

    Hi,

    If the unit is a AP7900 the latest firmware is available at this link. https://www.apc.com/shop/us/en/products/Switched-Metered-Rack-Power-Distribution-Unit-Firmware-Revision-3-9-2/P-SFRPDU392

     

  • ggiesen

    I'd like to mention I had similar issues with upgrades as OP. I have dozens of 79xx units, and the GUI tool never seemed to work, however it worked almost flawlessly with FTP.

    That being said, I've been unable to get the units to use an SSH2 host key size other than 768 bits. As of OpenSSH 7.6, host keys smaller than 1024 bits are refused with no way to override it (https://www.openssh.com/txt/release-7.6).

    I've tried using the WebUI to delete and regenerate the keys, and it only generates 768-bit keys (as it indicates it will).

    I've also tried using the APC Network Management Card Security Wizard CLI Utility (https://www.apc.com/shop/us/en/products/APC-Network-Management-Card-Security-Wizard-CLI-Utility-v1-0-1/P-SFNMCSECCLI101) to generate new SSH keys (both 1024 and 2048), and upload them via the WebUI, but it seems to eventually reject them and then generate a new 768-bit key.

    Is there any way to get these units to use an SSH key length of at least 1024 bits?

Page 1 of 1 (13 items)
Choose your language:  
powered by Communifire
Version 7.0.7496.13049