Loading ...

| Smart-UPS & Symmetra LX / RM

Home » Spaces » Smart-UPS & Symmetra LX / RM » discussion » General » UPS Not detected in Device Manager

UPS Not detected in Device Manager

Discussion in Smart-UPS & Symmetra LX / RM started by Chris , 3/11/2013 6:48 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

UPS Not detected in Device Manager

Subscribe to RSS
  • ipicKedawinna

    When you upgraded powerchute, did you remove it completely and then reinstall? What is the exact model of your old UPS (if you have it) and the new model UPS (from the white sticker on the back of the UPS)?

    have you tried a different computer?

    another thing might be to try and braindead the UPS if at all possible. this involves turning off the UPS (and probably any attached load first) and then removing AC power from the UPS. then, you can either disconnect the battery for 20 seconds (or the battery disconnect) and hold down the off/power button during this time. you'd also want to remove any connected data (USB) cables to the UPS so we can do a full reboot of the unit and rule out any UPS communication issues.

    That is how i'd start and if we're still in the same spot, there might be a few other steps. if you'd like first, tell me what UPS model you had and that you have now, then I can tell you if i'd still suggest the braindead steps.

  • cwald

    The new 1500 UPS was installed before the old software (7.0.5) was removed and the new software (9.0.5) installed. It wasn't detected so I've tried a reboot of the server and different USB ports/cables to try to get the auto detect to kick off. Old UPS: AS0821140958, New UPS: AS1110122323 (Are these the numbers you're talking about?

    We have refreshed approximately 15 UPS devices and have had this happen on 2 so far. The other 13 worked with no issues.

    Thanks for the info Angela!

    Chris

  • ipicKedawinna

    Hi Chris,

    I am looking for the models - what you gave me is the serial number. I am looking for something like SMT1500 or SUA1500 for the model number. If the UPS has an LCD on the front, you can find it there or on the back.

    I am just wondering because the type of the UPS communications might matter when dealing with PowerChute so I need to verify what models they are so we need the communication type. If the old UPS was a different type of communication, I believe the agent needs to be removed and completely reinstalled so that is why I was asking how exactly the uninstall/reinstall between 7.0.5 and 9.0 went.

  • cwald

    The old model is a DLA1500 and the new model is a SMT1500.

  • wpasquil

    Chris,

    Attach the UPS via USB to the system and run USBDeview.exe (link to USBDeview.exe - freeware http://www.nirsoft.net/utils/usb_devices_view.html)

    If the UPS is being detected it will show in the attached devise list. If it still does not show and you have a Windows laptop attach that to the UPS via USB and run USBDeview.exe from that system. This will indicate if the issue is with the original system or the UPS.

    PCBE USB drivers can be found in C:\Windows\System32\DriverStore\FileRepository

    The driver needed for an SMT on 32 bit system is apcups.inf_072ffa08

    On 64 bit system the driver is apcups.inf_amd64_neutral_bea1b5a2ba50a0f7

    You should also check to be sure the hidclass.sys, hidparse.sys, and hidusb.sys are in C:\Windows\System32\drivers


  • ipicKedawinna

    I'll defer to Bill P. on this one as I don't work with this type of thing much and I am not sure what your results indicate.

    Bill - got any other ideas based on Chris's feedback with the utility you suggested?

  • cwald

    HI Angela,

    I ran the USBDeview.exe from a working server and I see the below screenshot. I also checked and the server DOES have "C:\Windows\System32\DriverStore\FileRepository\driapcups.inf_amd64_neutral_bea1b5a2ba50a0f7".  It also has the three files hidclass.sys, hidparse.sys, and hidusb.sys located in "C:\Windows\System32\drivers".

    1042_pastedImage_2.png

    From the non working server it looks like the following. It also DOES NOT have "C:\Windows\System32\DriverStore\FileRepository\apcups.inf_amd64_neutral_bea1b5a2ba50a0f7". I do have three files hidclass.sys, hidparse.sys, and hidusb.sys located in "C:\Windows\System32\drivers".

    1041_pastedImage_1.png

    Can I copy that directory over to the non working server?

  • cwald

    Hello,

    I had a APC 1500 UPS connected to my server and was able to manage the UPS without issues using PowerChute Business Edition 7.0.5 software. As part of a refresh cycle we have replaced that 1500 UPS with a newer model 1500 UPS. But once the new UPS was installed the server couldn't detect the new UPS. I have tried multiple USB ports on the server as well as different USB cable all together. I also tried upgrading the PowerChute software to the latest version 9.0.1 but still nothing shows up in the device manager.

    I ran the utility pnputil.exe -e from a command prompt but i don't see anything related to a APC UPS in the list of driver packages.

    Has anyone come across this before?

    Thanks in advance!

    Chris

  • cwald

    Hi Angela, have you had a chance to talk to Bill about any possible suggestions to get this working?

    Thanks,

    Chris

  • ipicKedawinna

    Hi Chris,

    Bill is doing a training right now but he did say he was looking into it and waiting for someone to get back to him to verify before he gave you any instructions.

  • cwald

    Perfect thank you!

  • wpasquil

    Chris,

    What OS/s are you running and when you look at Device Manager / Batteries do you see HID UPS Battery? Also in Device Manager do you see under Human Interface Devices American Power Conversion USB UPS?

  • cwald

    We are running Windows Server 2008 R2 x64

    In Device Manager I don't see the HID UPS Battery and I don't see the American Power Conversion USB UPS in the Human Interface Devices. Because I don't see anything in the Device Manager I tested the USB cable by plugging it into a laptop vs the server and the UPS was detected by the laptop. I also tried plugging a USB mouse in the same USB port on the server and the server detected the mouse. So for some reason the server just doesn't detect the UPS and install the necessary driver.

    Chris

  • ipicKedawinna

    I was looking at this again and thinking it was maybe because the server doesn't have legacy USB (1.1) enabled (considering there is no "unknown device" even detected) but all of the UPSs are still 1.1 and the old one worked..

  • cwald

    Its strange, I've tried different USB ports on the server, a different USB cable, plugged different USB devices into the server, and tried connecting the UPS to a laptop and it detected no problem. So I've test each component successfully.

  • cwald

    Any ideas Angela/Bill?

  • wpasquil

    Hi,

    As a matter of interest have you tried swapping a unit from a system that works with a unit from a system that does not work? I understand that you tested with WinXP and units that don't work with the Win2008 Servers do work but it would be nice to know if the issue definitely stays with those 2 servers and not the UPS while attached to Win2008.

    Also, what is the firmware revision of a UPS that does work with Win2008 and what is the firmware of the 2 units that do not work? You can get the firmware info from the LCD panel on the UPS under the about heading. Example Firmware 1 = UPS 03.8 Firmware 2 = Com 03.8 Firmware 3 = UBL 05.0 Firmware 4 = CBL 04.1

  • spock

    I experienced the same issue you described and I used the utility above to uninstall the previous instances of APC devices as well as all usb drives that were no longer in use on the server- ie; flash drives and old USB drives. After the original APC was removed, I went to Device Manager for the server and selected Scan for  Hardware changes.

    The server detected the APC connected via usb and installed the correct driver from Windows update. The APC Power chute software then recognised the the device and allowed it to be configured.

    A hearty THANK YOU to  the user that posted the link to USBDeview that little utility is now on my memory stick of valuable tools!

  • RichM-DCA

    I'm also having this exact problem with an SMT3000RMI2U on a Windows 7 x64 machine. No HID UPS Battery in Device Manager after scanning for hardware changes or rebooting machine.

    I do not know what firmware is installed on the UPS yet (it's in an awkward location but I should be able to find out later).

    I've tried the USBDeview utility and nothing is showing up on this. I've tried several USB ports on the back of the machine with the same result. There are other USB devices plugged into the machine and these are working so I do no suspect the ports.

    There is no driapcups.inf_amd64_neutral_bea1b5a2ba50a0f7 or apcups.inf_amd64_neutral_bea1b5a2ba50a0f7 in C:\Windows\System32\DriverStore\FileRepository\

    I have the three files hidclass.sys, hidparse.sys, and hidusb.sys in C:\Windows\System32\drivers

  • wpasquil

    Hi,

    Do you have a Windows laptop you could connect to the UPS to test the USB comm? 

Page 1 of 1 (20 items)
Choose your language:  
powered by Communifire
Version 7.0.7496.13049