Loading ...

updating firmware on mid 2011 smt1500 issues | Smart-UPS & Symmetra LX / RM

Home » Spaces » Smart-UPS & Symmetra LX / RM » discussion » General » updating firmware on mid 2011 smt1500 issues

updating firmware on mid 2011 smt1500 issues

Discussion in Smart-UPS & Symmetra LX / RM started by flint , 1/4/2021 11:53 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

updating firmware on mid 2011 smt1500 issues

Subscribe to RSS
  • i recently went out to a client who has 6 of the smt1500 in use. one has an issue i posted about in another thread. id like to update the firmware on them all to the newest possible i did buy the correct cable as listed on the apc site here https://www.apc.com/us/en/faqs/FA163632/ and am following the instructions that are also on the apc site. the firmware upgrade software i guess can not update this unit with usb so using that serial cable to an ACTUAL serial port not a usb to serial cable adapter the software can not find the unit no matter what i do. the serial port works fine on this desktop and i can see that the smt1500 is connected just that the firmware update tool can not find it. any suggestions?

     

    thanks!

  • HI Flint,

    Can you please say which firmware the unit is currently on and what the ID for the firmware is?

    Also what is the serial number of the unit.

    See info below for some details regarding serial number.

    • Legacy Devices:  Models beginning with: SU, SUA, SUM, SC, SURT, SURTD, SURTA, SRC (IE: SUA3000XL, SU2200NET, SURTD3000RMXLT)

    • Next Generation Devices: SMX750, SMX1000, SMX1500 with firmware UPS 02.x or lower.

      • These units are 120 V devices built prior to date code 1037. Date code is the first 4 numbers in your serial number. (IE: Serial Number AS1036123456 Would not be supported.)

  • all of them are newer the 1037 i already checked all of that i think the current firmware is 5.0 but ill have to double check

     

  • Please also check the firmware ID and send through the unit serial number.

    The older versions of the firmware might not be in the latest release of the firmware upgrade utility and I might have the required firmware file.

    Which is why I need to the ID.

    The serial number is to reference previous units we worked on to see if we had issues like this before.

  • serial number is AS1108120569

    firmware 1: 05.0

    firmware 2: com 02.1

    firmware 3: vbl 05.0

    firmware 4: cbl 5.21

    this is all from the display screen dont see an id anywhere and cant get it to connect to the computer to check anything else. 

  • I have had a look through all the files I have and none seem to show the transition from 5.0 to anything higher.

    My only guess at this stage would be that you can no longer upgrade this due to a compatibility issue with the Firmware Upgrade Utility (FWU.

    Not sure which version you are using but I have linked a old version 4.1.1 which you can try if you want.

    https://schneider-electric.box.com/s/fg9pvls6l9l213mz8guw2qh6976rxbn7

    Failing that I would suggest making contact directly with support and ask them to send another version of the FWU

    Sorry for not being able to help further.

    I have added a txt file which show versions and compatibility that shows that your likely next upgrade is:

    SMT                    17                UPS 07.1               SMT17UPS_07-1_Le.enc

  • when i spoke to them via a phone call they said i should be able to go to version 7.1 so i am just not sure. the newer firmware have a slightly different display info wise and things and we would have liked them all to match across the board which is why they want them upgraded. they have a few on 7.1 and 2 on this 5.0 version. ill install powerchute here on my laptop and see if i can connect via usb and see if it tells me more info. i was trying 4.2.1 update software

  • so i did find out this is a id 17-2 unit shown in powerchute. any ideas if this can still be updated? or is this why it can not be updated. i can not find anything anywhere that says it can not be. just that pre 1036 can not be and if lower then 8.0 you can only go to 7.1 and above 8.0 you would go to 9.3. the client for some reason really wants them all to show the same display and im hoping this can be done. what would be the difference between 17 and 17-2??

     

    thanks again

  • Hi Flint,

    As far as I know the display is not going to change when you do the firmware upgrade. They only add some improvements to certain features which can be seen in the .txt files in the FirmwareFiles folder under the firmware utility folder. There is no file for 05.0 to 07.1 so I don't know what has been improved or updated.

    You mentioned the client want the screens to all show the same display, can you clarify what you mean by that? On the physical display or in powerchute? Make sure you change the display from Standard to Advanced under Configuration for all the units since that ensure you have all features available on the display. This is on the physical display.

    In regards to being able to upgrade I can't provide more info and I don't have a example from previous units at this stage.

    You can contact SE on the link below and go through the chat system and they might be able to provide more info

    https://www.se.com/nz/en/work/support/customer-care/contact-schneider-electric.jsp

  • i contacted them via phone 2x one rep told me it should be fine to update to 7.1 the other one said there is no update for this unit. 

    what they want to match is the info displayed. for some reason these units on 5.0 do not show the same info even when set to advanced. as the menus change on the home screen. which they want them to do where they scroll through the info. i cant say why. but the 7.1 / 9.1 / 9.3 units they also have show more info and are worded differently then the 5.0 ones. again with both set to advanced. 

    i appreciate the help from you and it was not you i was upset with or anything like that i just was told by one rep on the phone when i called they should update fine. then a second call told me you cant update these units? i am not new to updating them. i have done many actually in the past for other people so when i could not get these to work even though it said id17 even myself i questioned why. 

    i am just trying to do what the client asked of me and of course id like to get paid for the job at hand but i will not know and all the time and effort i put into messing with these is for nothing now. if you can not update the 7-2 units they really need to specify that somewhere imo the reason is the client did look on the site and saw it said 17. but imo they need to add something to that chart that says 17 does not include 17-2. just a bummer i have multiple hours in now and will not get paid for that time. again not at all your fault. i do appreciate your time and effort to help for sure. thank you!

  • ok so i have accomplished what apc told me a few days ago you could not do. i have 17-2 units on firmware 07.1. can take pics to prove it. 

    so i tried the proper smart cable direct to serial port. no luck. tried a serial to usb cable i had on hand no luck. then i decided to try a different chipset serial to usb cable. the one i was using was the prolific chipset. the one that worked in the end was the ftdi serial to usb cable. NO IDEA why these would not communicate through serial directly though. that doesnt make any sense and i tested the serial port on the computer with other devices i was using and it worked perfectly as did it with another unit we updated to 9.3. i also did try another desktop and yet another laptop with serial built in. 

    so in the end i used the ftdi cable after the correct smart cable and the 4.2.1 firmware tool found the unit and showed 7.1 as the new firmware and the updates went through perfectly. no issues. very odd that this was the only was to get it to see them though. the units are on 7.1 with id 17-2 and everything works i tested all functions on the units. 

  • Thanks for the update. Will have to add that to our repair schedules for these older version units to make sure we can get them updated.

    Which prolific cable were you using and which FTDI cable?

  • the prolific i tried 2 different ones. dont know the exact brand of them since ive had them for a while. but they are the pl-2303 chipset (real ones not the fake ones going around) and the ftdi cable i used was this exact one brand and chipset in the 6.6ft length here: https://www.amazon.com/gp/product/B0758BMXBG/ref=ppx_yo_dt_b_asin_title_o02_s01?ie=UTF8&psc=1

    been testing them on and off all day also to make sure everything is properly working and i see no issues everything properly working 100%. hopefully it will help someone else out who might have this same issue. i also had one of the 5.0 17-2 units that had some weird issue where it would randomly shut itself off so it was no longer in use. updating it to 7.1 seems (so far) to have fixed whatever the issue was with that unit. at least so far in the past roughly 18 hours or so it has been fine. ill have to wait and see if it happens again. i do notice the fan might be quieter going from 5 to 7.1 but it might be my imagination it doesn't seem to run as often on high. 

Page 1 of 1 (13 items)
Choose your language:  
powered by Communifire
Version 8.0.7732.32596