Loading ...

NMC2 (AP9631) only sends some Email notifications | Smart-UPS & Symmetra LX / RM

Home » Spaces » Smart-UPS & Symmetra LX / RM » discussion » General » NMC2 (AP9631) only sends some Email notifications

NMC2 (AP9631) only sends some Email notifications

Discussion in Smart-UPS & Symmetra LX / RM started by Janic , 14 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

NMC2 (AP9631) only sends some Email notifications

Subscribe to RSS
  • admin888

    NMC2 Firmware version: 6.8.8

    Model number: AP9631

     

    We've had a UPS (SURT15KRMXLT) with an NMC2 for 8 years now. The Email notifications have always worked fine. Ever since I upgraded to a newer firmware last year, we have been having problems with the notifications. It’s a simple configuration: The UPS sends via an internal SMTP without authentication, the test always works.

     

    When the UPS does a self-test though for example, it always only sends the “Self-Test started.” E-Mail, not the follow-up (“Self-Test passed.”). When I check the log, it says: “Email: Could not mail mailrelay.contoso.local”

    The first Email from 20:47:55 arrived, but that’s it:

    When I check the message tracking on our Exchange (the SMTP for the UPS), I only see one Email being submitted by the NMC:

    Emails for “Self-Test passed” are activated:

    Another example: We had a power outage recently, the only Email we received was about the power being back on (I already suspected a switch or something being out during the outage and that causing the lack of Emails but I can check that off, especially because this also happens with the self-tests during normal operation).

    Once again, the log from our Exchange server from that day, the only Email it received from the UPS was “No longer on battery power.”

     

    The Email alert for “On battery power” is on:

    Any ideas?

  • wpasquil

    Hi,

    You should see that error if the NMC cannot connect to the SMTP server or in your case the relay to send the mail. What firmware were you running prior to the upgrade? 

  • admin888
    On 9/4/2020 9:55 AM, Bill said:

    What firmware were you running prior to the upgrade? 

    The one the NMC came with, so from 2012. It just makes no sense to me that the NMC can reach the SMTP server one minute and the next one it can't (during normal operation). It's definitely not on the SMTP server side, we have dozens of devices using it constantly without problems. Anyway, I'll test some more and report back if I make progress.

  • APC_Gavan

    Hi Janic,

    Try to replace the SMTP's hostname with it's IP address and see if that helps.

    -Gavan

  • admin888
    On 9/16/2020 4:09 AM, Gavan said:

    Try to replace the SMTP's hostname with it's IP address and see if that helps.

     

    Nope, this time the NMC didn't even send one E-Mail:

    Just now I sent a test email again which works without problems as usual:

    I'm starting to think the NMC is faulty with how inconsistent this problem has been. I'll upgrade to firmware 6.9.2 and see if that helps.

  • APC_Gavan
    This discussion is marked as answered

    Hi Janic,

    I doubt it's an NMC fault, NMCs are very all or nothing, they either work or they don't.

    Is the NMC on the same subnet as the mail server? If no can it be moved onto the same subnet, that is the first thing I would do.

    -Gavan 

  • admin888
    This discussion is marked as answered
    On 9/18/2020 3:56 AM, Gavan said:

    I doubt it's an NMC fault

    Seems you are correct. I tested with a different SMTP server and so far it seems to work reliably. I didn't suspect our Exchange as the culprit since it works fine with all of our other devices. I'll have to test further to see what the problem between the NMC and our Exchange is. Thanks.

  • APC_Gavan

    Exchange has a lot of "smart" integrated anti-spam and security features, but some times it can be too "smart" for what you actually want to do.

    -Gavan

Page 1 of 1 (8 items)
Choose your language:  
powered by Communifire
Version 7.0.7496.13049