Loading ...

SMT1500 recover from failed firmware update | Smart-UPS & Symmetra LX / RM

Home » Spaces » Smart-UPS & Symmetra LX / RM » discussion » General » SMT1500 recover from failed firmware update

SMT1500 recover from failed firmware update

Discussion in Smart-UPS & Symmetra LX / RM started by Alexandre , 5/15/2020 4:55 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

SMT1500 recover from failed firmware update

Subscribe to RSS
  • saldru

    Hi everyone,

    I recently bought a SMT1500 UPS with a AP9630 NMC card.

    I proceeded to upgrade the firmware of the NMC card from v6.0.1 to v6.8.0 with the Firmware Upgrade Utility v2.20. It worked well and the NMC card was updated. Then on the web site of APC, they recommended also to update the firmware of the SMT1500 (ID18) to the latest version from UPS 08.8 to UPS 09.4. I used the option to update it via the NMC card. I downloaded the firmware from the APC website named "SMT18UPS_09-4.enc, then I turned off the output power of the UPS and I uploaded the firmware to upgrade it. However, the upgrade process was still running after 20 minutes. So I opened a new tab in my browser and I saw I was logged-off. I tried to go back on the update page and the page was still "updating'. I waited another 30 minutes and nothing changed. Only that I was logged-off again by the web interface of the NMC. So te last solution I found was to turn off the UPS. I unplugged the input power and I unplugged the battery port. I waited a minute then I plugged back the battery port then the input port. The fan started and the front LED screen started to make light but nothing printed on it, no LED were turned on and nothing happened when I pressed any front buttons. I plugged the 940-0625A cable to the Monitoring Port of the SMT1500 and I plugged it to my computer. I opened a TeraTerm terminal and I tried with all the baud rate from 2400 to 115200 and no output. 

    I went back in the NMC interface and I saw that the NMC didn't found the UPS.

    Later, I found that the default timeout of the NMC web interface was 3 minutes so I think I was logged-off before the uploading of the firmware was done but instead of giving me an upload error, the upgrade process continued and I think I corrupted the SMT1500 firmware.

    So, my question is that I want to know if there is a way to recover my UPS like with a boot prompt and XMODEM or any other solution ?

    Thank you in advance for your time and your help.

  • wpasquil

    Hi,

     See Schneider Electric FAQ FA281865 How do I update the firmware of my SMT, SMX, SMC, or SCL series Smart-UPS using the Firmware Upgrade Wizard?

     

  • saldru

    Hi Bill,

    Thank you for your feedback. Unfortunately I already tried this. I also tried to power-off the UPS then power it on and to try to upload the firmware with X-MODEM waiting for the ^C to print on the console terminal. Unfortunately I don't see anything and the firmware don't want to upload.

    How it's possible to break the bootloader ? The firmware should be broken and the bootloader should ask for a new one to be uploaded.

    There is no other possibilities to recover the UPS firmware ?

    Thank you for your time.

Page 1 of 1 (3 items)
Choose your language:  
powered by Communifire
Version 7.0.7485.25369