Loading ...

Network Management Card 2 - Failed Firmware Update - Cannot Recover | Smart-UPS & Symmetra LX / RM

Home » Spaces » Smart-UPS & Symmetra LX / RM » discussion » General » Network Management Card 2 - Failed Firmware Update - Cannot Recover

Network Management Card 2 - Failed Firmware Update - Cannot Recover

Discussion in Smart-UPS & Symmetra LX / RM started by David , 21 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

Network Management Card 2 - Failed Firmware Update - Cannot Recover

Subscribe to RSS
  • dma999999

    Hi there. I have an APC Smart-UPS (SMX3000RMLV2U) with a Network Management Card 2 (AP9630) installed. Recently I noticed an updated firmware was available for the card (6.7.2) and so decided to upgrade. The firmware that was installed was v. 6.5.0.

    I downloaded the package and ran it. Everything seemed to go fine, but when I tried to access the webui for the UPS, I was greeted with the dreaded "The Application Was Not Able to Load" message. I searched the forum for solutions and tried a few more things: First, running the updater repeatedly (didn't work) then attempting to manually update the firmware (using the instructions I found at https://www.apc.com/us/en/faqs/FA156047/#FTP). The bootloader did not need updating as it was the same version on the card as in the package, so I tried manually FTPing first AOS then SMX. The FTP uploads appeared successful, but I still got the same error message when attempting to access the webui.

    I also tried using an FTP program (FileZilla) to upload the AOS file to the root directory of the card but this also did not work. The upload was reported as successful but again, it did not solve the problem. However, I did notice that there was a file in the root directory called "apc_hw05_aos_650.bin". I suspected that might be causing the problem with the update, so I tried to delete it. However, I was unable to do so. I tried using both an FTP program and SSHing into the UPS and using the "delete" command. Neither worked. In SSH, the error returned was "E100: Command Failed". In the FTP program, it was "550 DELE requested action not taken."

    Following is the output of the "about" command when I SSH into the UPS:

    E000: Success
    Hardware Factory
    ---------------
    Model Number: AP9630
    Serial Number: ZA1433022827
    Hardware Revision: 05
    Manufacture Date: 08/16/2014
    MAC Address: 00 C0 B7 88 A9 63
    Management Uptime: 0 Days 0 Hours 9 Minutes

    Application Module
    ---------------
    Invalid Module Header!

    APC OS(AOS)
    ---------------
    Name: aos
    Version: v6.5.0
    Date: Jun 9 2017
    Time: 13:41:00

    APC Boot Monitor
    ---------------
    Name: bootmon
    Version: v1.0.8
    Date: Apr 8 2014
    Time: 10:59:40

    Any suggestions on how I could successfully complete the upgrade would be most appreciated. Alternatively, I would at least like to restore the ability to access the webgui and so would like to try to restore 6.5.0 of the application (i.e. the SUMX file) but I cannot seem to find it. I found a version of 6.5.0 but it indicated that it was for the Symmetra 3 Phase UPS, so was worried that might bork things up. If anyone happens to have a link to where I could find v. 6.5.0 for Smart-UPS units, that would also be most appreciated.

     

  • wpasquil

    Hi,

    Can you telnet to the card and if so send a screenshot of the opening page?

  • dma999999

    Here's the snap once I login:

    Schneider Electric Network Management Card AOS v6.5.0
    (c) Copyright 2017 All Rights Reserved
    -------------------------------------------------------------------------------
    Name : apcups Date : 2019-08-06
    Contact : Unknown Time : 20:29:04
    Location : Unknown User : Administrator
    Up Time : 3 Days 8 Hours 9 Minutes Stat : P+ N4+ N6+ A-

    Type ? for command listing
    Use tcpip command for IP address(-i), subnet(-s), and gateway(-g)

    apc>

     

  • wpasquil

    Hi,

    The A- indicates there is an issue with the application. Normally a reboot will correct the issue but as noted updating the firmware has not resolved this. Here is a link to the 6.5.6 firmware as I do not have access to 6.5.0. https://schneider-electric.box.com/s/wker10eq5fefbcm60mi1fhts25wlyds6

    I recommend flashing the firmware manually (FTP) to resolve and include the bootmon. see FAQ FA156047 

  • dma999999

    Bill, 

    Thanks very much for the firmware and the instructions for manual flashing. I downloaded the firmware and attempted flashing manually as you suggested, including the bootmon. The flashing process appeared to complete successfully each of the three times I tried it, but unfortunately I am still encountering the same problem. Moreover, even after three tries, it still seems to be stuck on v.6.5.0. Following is what is displayed when I SSH to the UPS:

    Schneider Electric Network Management Card AOS v6.5.0
    (c) Copyright 2017 All Rights Reserved
    -------------------------------------------------------------------------------
    Name : apcups Date : 2019-08-09
    Contact : Unknown Time : 00:22:20
    Location : Unknown User : Administrator
    Up Time : 0 Days 0 Hours 54 Minutes Stat : P+ N4+ N6+ A$

    Type ? for command listing
    Use tcpip command for IP address(-i), subnet(-s), and gateway(-g)

    apc>about
    E000: Success
    Hardware Factory
    ---------------
    Model Number: AP9630
    Serial Number: ZA1433022827
    Hardware Revision: 05
    Manufacture Date: 08/16/2014
    MAC Address: 00 C0 B7 88 A9 63
    Management Uptime: 0 Days 0 Hours 54 Minutes

    Application Module
    ---------------
    Invalid Module Header!

    APC OS(AOS)
    ---------------
    Name: aos
    Version: v6.5.0
    Date: Jun 9 2017
    Time: 13:41:00

    APC Boot Monitor
    ---------------
    Name: bootmon
    Version: v1.0.8
    Date: Apr 8 2014
    Time: 10:59:40

    apc>

    Please do let me know if there might be anything else I could try. I should perhaps also mention that the 6.5.0 file I mentioned earlier is still in the root directory and attempts to delete it have been met with the same error message. 

     

Page 1 of 1 (5 items)
Choose your language:  
powered by Communifire
Version 6.0.7119.9640