Loading ...

ES700 not powering on after battery drain | Back-UPS & Surge Protectors

Home » Spaces » Back-UPS & Surge Protectors » discussion » General » ES700 not powering on after battery drain

ES700 not powering on after battery drain

Discussion in Back-UPS & Surge Protectors started by Peter , 9 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

ES700 not powering on after battery drain

Subscribe to RSS
  • I have an ES700 which is approximately 2 years old (warranty replacement, so may have been refurbished) and whose battery is, or at least was, in good condition.

    Yesterday morning we had a power cut and the UPS kicked in as expected, giving time for me to shut down PC and NAS and half-charge my phone in case it was a long outage. Eventually the low battery warning (constant rapid beeps) started and I possibly made the mistake of turning it off to keep it quiet. When the power came back on the surge protection sockets work as normal, but the power button does nothing and the backup sockets have no passthrough power. It's now been connected to utility power while turned off for over 24 hours so should have recharged fully.

    I've tried:

    • Holding down power button for over 30 seconds, both while connected to AC and disconnected.
    • Disconnecting and reconnecting battery. I then tried to turn on while unplugged from AC and got very short then long beep and nothing more. Reconnected to AC and power button once more does nothing.
    • Checked that circuit breaker button hasn't popped out.

    Any suggestions for what to try next gratefully received!

  • Plug the UPS into a working AC outlet and attempt to power on. If the UPS powers on, allow the unit to charge for at least 24 hours before returning to storage. If the unit does not power on consider replacing the battery.

    TelltheBell Survey

Page 1 of 1 (2 items)
Choose your language:  
powered by Communifire
Version 8.0.7757.16597