Loading ...

Back-UPS Pro 550 not charging battery when powered on | Back-UPS & Surge Protectors

Home » Spaces » Back-UPS & Surge Protectors » discussion » General » Back-UPS Pro 550 not charging battery when powered on

Back-UPS Pro 550 not charging battery when powered on

Discussion in Back-UPS & Surge Protectors started by Geoff , 11/19/2020 7:50 AM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

Back-UPS Pro 550 not charging battery when powered on

Subscribe to RSS
  • Hi!

    I have a Back-UPS Pro 550. After replacing the battery, I realised that my unit was not charging the battery anymore when powered ON. Tests I have conducted so far:

    1. If the unit is powered ON, the battery does not charge
    2. When powered ON and I disconnect the battery I can measure 13.78V on the battery poles, so Voltage is there from the DC converter
    3. When I shut down the UPS, then the battery starts charging: I see the voltage slowly increasing and after 2 days the battery was 100% charged

    Based on the above it seems to indicate that charging circuit is OK, but it might be a SW issue or some failing sensor that cuts battery charging ? Is there any reset function or FW update that I could apply ? Anything else I could check / do to fix it ?

    The unit is around 5 years old so not covered by warranty but still not that old :-)

    Thanks

  • Hi,

    You can try and brain dead the UPS to reset it.

    See Schneider Electric FAQ FA158947 for instruction. 

  • the basic troubleshooting steps for the APC Back-UPS Pro with ... The Back-UPS is not connected to AC power, there is no AC power ... The battery will not charge if the temperature is over 50 degrees Celsius 

  • This discussion is marked as answered
    On 11/19/2020 12:19 PM, Bill said:

    You can try and brain dead the UPS to reset it.

    Hi, thanks for the replies. I did try a brain dead reset + another type of reset I find on the internet, no success.

    After opening the device I located a bad capacitor (see picture).

    After replacing it, the charging process of the Battery is working again!

    Thanks for the quick answers and the help.

  • I have the same problem with this model.

    APC wont do anything. It seems to be a problem with this model.

    I will give a try to search for the capacitor. Thx for the input.

Page 1 of 1 (5 items)
Choose your language:  
powered by Communifire
Version 8.0.7732.32596