Loading ...

Back-UPS 1000 NEW blinking battery icon | Back-UPS & Surge Protectors

Home » Spaces » Back-UPS & Surge Protectors » discussion » General » Back-UPS 1000 NEW blinking battery icon

Back-UPS 1000 NEW blinking battery icon

Discussion in Back-UPS & Surge Protectors started by Dustin , 5/7/2020 1:38 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

Back-UPS 1000 NEW blinking battery icon

Subscribe to RSS
  • dustinnulf

    Hi, just got a BRAND new APC Back-UPS device, plugged in the red wire, plugged in the power plug. Battery icon is blinking. So I let the device charge overnight but the battery icon is still blinking. No bars within the battery icon. It appears to not be charging. ?

    Also, there's a black wire on the battery. Does it need to be connected, too?

    Other ideas? Do I need to return the device for a different one?

    Thanks. 

  • wpasquil
    This discussion is marked as answered

    Hi,

    Both the red/positive and black/negative wires must be connected for the battery to work properly. 

  • dustinnulf
    On 5/7/2020 4:20 PM, Bill said:

    Hi,

    Both the red/positive and black/negative wires must be connected for the battery to work properly. 

    That's it, Bill! Thank you. I recommend the image and instructions in the manual be updated. It refers to only a single wire, and only one wire is circled in the image, which led to my hesitation. But thanks again! Working properly now.

     

Page 1 of 1 (3 items)
Choose your language:  
powered by Communifire
Version 7.0.7485.25369