Loading ...

New BackUp Pro BR1500MS Questions | Back-UPS & Surge Protectors

Home » Spaces » Back-UPS & Surge Protectors » discussion » General » New BackUp Pro BR1500MS Questions

New BackUp Pro BR1500MS Questions

Discussion in Back-UPS & Surge Protectors started by John , 9/15/2019 7:57 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

New BackUp Pro BR1500MS Questions

Subscribe to RSS
  • John_E

    Set up a new UPS last night by connecting battery, turning on and charging for 16 hours with no load connected. All seems okay but have a few questions:

    1. What should the run time display in minutes now show after charging with no load? Both of my old XS 1500 units displayed 785 when fully charged. Lost one of them  on Friday (9 years old) and this new unit is replacing it.

    2. I charged with the unit being turned on but nothing connected. Does it still charge when the unit turned off?

    Just curious and getting used to the new one as it is different from the old ones. Assume the remaining unit will go out soon. We do get frequent power outages here and they are a headache.

    Thanks...

     

  • wpasquil

    Hi,

    On 9/15/2019 3:57 PM, John said:

    1. What should the run time display in minutes now show after charging with no load? Both of my old XS 1500 units displayed 785 when fully charged. Lost one of them  on Friday (9 years old) and this new unit is replacing it.

    The runtime chart states that with a 50 watt load the UPS should provide 2 hours and 11 minutes of runtime. Here is a link to the Chart.

     https://www.apc.com/products/runtime_for_extendedruntime.cfm?upsfamily=27

    On 9/15/2019 3:57 PM, John said:

    2. I charged with the unit being turned on but nothing connected. Does it still charge when the unit turned off?

    Yes, assuming it is connect to AC source. 

     

  • John_E

    Thanks for replying, Bill.

    Nice chart that I'll keep but it does not show what a fully charged unit should show on display. Mine has showed 179 minutes since I first turned it on. Seems that kind of jives with the chart but...

Page 1 of 1 (3 items)
Choose your language:  
powered by Communifire
Version 6.0.7207.29305