Loading ...

Back-UPS Pro 1500 | Back-UPS & Surge Protectors

Home » Spaces » Back-UPS & Surge Protectors » discussion » General » Back-UPS Pro 1500 - battery blinking, before it needed replacement

Back-UPS Pro 1500 - battery blinking, before it needed replacement

Discussion in Back-UPS & Surge Protectors started by Marcin , 1/11/2018 7:37 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

Back-UPS Pro 1500 - battery blinking, before it needed replacement

Subscribe to RSS
  • Hello

    I've bought this UPS 2years and 2 months ago, devices connected to it (PC and displayes) are turned on 24 hours. Load is 25% or less according to display. There was no problem with UPS win past.

    Yesterday I've heard noice and saw battery needs replacement icon on display. I've turned off, removed battery, put it again, tried it several times. I've also pressed power button for more than 5 seconds. 

    However the situation now is like this - there is no battery needs replacement icon any more but battery icon is blinking. In Powerchute personal edition I've chosen that I've replaced battery (what is not true - I've put exactly the same battery) and I cannot run manual self-test (button is inactive).

    Question - does it mean that battery really needs replacement or maybe there is something else going with UPS? I haven't noticed any other problems, there are no Fxx codes on display, before UPS was making self-test from time to time and everything was always fine (last self-test was passed 27.12.2017).

    Is it somehow possible I haven't put battery right? ( I don't hear any click or something like this when I push it).

    This is screen from my Powerchute:

  • This discussion is marked as answered

    I've completely turned off UPS this night, after turning on it was switching between full battery and battery needs replacement. I've pressed turned off button for about 1 second and now it's showing again battery 60% loaded, no blinking, no battery replacement. However when I've tried to run self-test in PowerChute I've got "Unable to carry out a self-test at this time" 1 st time and when I tried to do it second time It passed. However after this it seems UPS is running this self-test all the time, it's switching between battery and normal power.

  • Hi,

    Try resetting the unit

    1: Disconnect any attached load.

    2: Unplug the UPS from the wall socket.

    3: Disconnect the UPS' internal battery.

    4: Push and hold the "On" button on the UPS for 5 seconds

    5: Reconnect internal battery.

    6: Plug UPS in to known good power source.

    7: Turn UPS on.

    If resetting does not correct the issue contact local support. They will assist you.

    Local support contact information is available at http://www.apc.com/pl/pl/support/contact-us/index.jsp

  • This discussion is marked as answered

    ^ This worked for me. Same issue as above with a full battery and empty battery signal alternating flashes. Following those steps has it working again normally. About a 4 year old battery.

  • Issue is back after a few days. Any suggestions?

Page 1 of 1 (5 items)
Choose your language:  
powered by Communifire
Version 8.0.7757.16597