Loading ...

Lost USB comms after a killpower - BX700U | Back-UPS & Surge Protectors

Home » Spaces » Back-UPS & Surge Protectors » discussion » General » Lost USB comms after a killpower - BX700U

Lost USB comms after a killpower - BX700U

Discussion in Back-UPS & Surge Protectors started by John , 1/6/2018 5:26 PM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

Lost USB comms after a killpower - BX700U

Subscribe to RSS
  • I have recently purchased a BX700U and am using it with apcupsd on three small servers and a  router, where the servers run Ubuntu 16.04 and Debian Stretch.

    I have been taking my setup through test cycles as I understand the operation of the BX700U and the apcupsd software for my first time.

    The following has happened to me twice now, and would be ridiculous if occurs regularly as I envisage unattended use...

    (a) I remove the power to the UPS and let the Master and two Slave work towards their shutdowns....
    (b) The Master issues a apcupsd --killpower followed by a shutdown -h now
    (c) as expected the Master shuts down and moments later, the UPS powers off.
    (d) the total power draw is about 25%, and I am testing with a TIMEOUT 240 parameter, so the battery is not being discharged by anything significant.
    (e) When the Power to the UPS is restored, all devices power up as expected.
    (f) HOWEVER there is no USB comms to the UPS.
    (g) the fix (so far twice) is to power off the UPS and remove the Yellow plug, and leave overnight.
    (h) Clearly ridiculous. Is this a known problem? Do I have a faulty unit?
    (i) This is NOT a problem with the USB cable, the USB port or the Server itself. All have been checked by substitutions, including the Powershute software on Windows 10. (g) is currently my only fix.

    UPS manufactured 3rd Dec 2017
    Software version : FIRMWARE : 924.Z3 .I USB FW:Z3

    Advice please
    Thank you
    John

  • Hi,

    The UPS should restore communication when it powers up. Is the UPS powering down completely? 

    On 1/6/2018 12:26 PM, John said:

    (g) the fix (so far twice) is to power off the UPS and remove the Yellow plug, and leave overnight

    What you are describing is similar the Bran Dead procedure. 

    1: Disconnect any attached load.

    2: Unplug the UPS from the wall socket.

    3: Disconnect the UPS' internal battery.

    4: Push and hold the "On" button on the UPS for 5 seconds

    5: Reconnect internal battery.

    6: Plug UPS in to known good power source.

    7: Turn UPS on.

    When the unit is brain dead the unit is reset so by you disconnecting the battery over night is appears the unit is resetting. 

  • Hi Bill,

    I have similar issue. In fact this is the second time when that happened.

    I returned the first unit thinking something went wrong (because USB socket was a bit flimsy) and now it happened with the replaced unit as well.

    What had happened with me was that:

    1. I plugged the brand new UPS to a wall socket.

    2. Plugged USB cable to my server which was powered from another power source at that time (so nothing was connected to the UPS power sockets).

    3. Server could communicate with the UPS.

    4.Once I saw that working I moved all my stuff - router, WiFi and the server itself (it was a small Intel NUC machine) and plug all of them to the UPS.

    5.Powered the UPS up.

    6.Once server booted, I checked how it worked - no communications at all. In fact there was even no usb port created in linux, lsusb showed nothing, no reactions on inserting/removing the cable.

    Now the process you described above - should that be performed every time the UPS starts or when???
    I just confuse as to why that issue happens at the first place and how to fix that PERMANENTLY?! (Apart from swapping APC ups to some other, cheap Chinese models that actually do work without that headache) ?

    thank you. 

  • Hi,

    Sorry for the inconvenience. The UPS should not lose comm with the computer after a restart. I suggest performing the reset procedure to resolve but no the procedure should not need to be done each time the system restarts. 

  • Hi All,

    I just bought a new Back-UPS XS 700U.

    In order to try the efficiency of this new power device, after the full charge, I cut the power before the APC (with 10w of device behind the APC - 1 internet modem + 1 Raspberry PI + 1 smart device to pilot the roller shutters... No powerfull devices...)

    The APC does the job fine, keep the power to these devices during 15  minutes as expected (no load shutdown is defined for power < 15w) .  Then, the APC sends the shutdown signal (using the USB cable plugged between the APC and the raspberry pi) to ask raspberry Pi to shutdown. It works fine, all is OK...

    BUT, after the power recover, the APC restarts , the plugged devices restarts well , but the USB communication to the raspberry pi  is not working (no USB device detected using "lsusb"). Even if I'm trying to connect other PC / laptops etc... The USB port on the APC is frozen. It is fully inactive...

    I follow the steps to recover the USB (remove the power plug of the APC, the yellow plug, wait few minutes than I re-plug all again). USB is recovered after that.

    It is not normal to initiate a hard restart of the APC (removing the yellow plug) to recover the USB.

    I do the test 2 times, each time, the USB port is broken...

    Is the firmware of the APC has a known bug ? How to correct that ?

    The APC is under warrranty... May I return back the APC to Amazon ? Is it a known bug ?

    Thank your for your answer.

     

    root@hassbian:/var/log# apcaccess status

    APC      : 001,036,0870

    DATE     : 2019-07-16 21:25:35 +0200

    HOSTNAME : hassbian

    VERSION  : 3.14.14 (31 May 2016) debian

    UPSNAME  : UPCBX700

    CABLE    : USB Cable

    DRIVER   : USB UPS Driver

    UPSMODE  : Stand Alone

    STARTTIME: 2019-07-16 21:23:33 +0200

    MODEL    : Back-UPS XS 700U

    STATUS   : ONLINE

    LINEV    : 234.0 Volts

    LOADPCT  : 2.0 Percent

    BCHARGE  : 100.0 Percent

    TIMELEFT : 160.5 Minutes

    MBATTCHG : 5 Percent

    MINTIMEL : 3 Minutes

    MAXTIME  : 0 Seconds

    SENSE    : Medium

    LOTRANS  : 140.0 Volts

    HITRANS  : 300.0 Volts

    ALARMDEL : 30 Seconds

    BATTV    : 13.4 Volts

    LASTXFER : No transfers since turnon

    NUMXFERS : 0

    TONBATT  : 0 Seconds

    CUMONBATT: 0 Seconds

    XOFFBATT : N/A

    SELFTEST : NO

    STATFLAG : 0x05000008

    SERIALNO : 3B1840X77987

    BATTDATE : 2018-10-07

    NOMINV   : 230 Volts

    NOMBATTV : 12.0 Volts

    NOMPOWER : 390 Watts

    FIRMWARE : 924.Z3 .I USB FW:Z3

    END APC  : 2019-07-16 21:26:12 +0200
  • Hi Bill!

    I have obtained the same unit: BX700U-GR and it has exactly the same problems as others mentioned. After initiating shutdown, the USB port is unresponsive and only cutting the power completely restores it back.

    This is obviously not the way things should work and it actually prevents me in using the device as I often don't have physical access to it. Is there any way to mitigate this problem? What should I do with the device? Which devices are known not to suffer of this or similar problems?

    Thanks a lot! 

  • Hello,

    Are you using APCUPSD or PowerChute to command the UPS off?

  • On my side, a full hard reset solve the problem.  (not only remove the power plug of the APC, the yellow plug, wait few minutes than I re-plug all again). but I follow the steps for Bran Dead procedure :

    1: Disconnect any attached load.

    2: Unplug the UPS from the wall socket.

    3: Disconnect the UPS' internal battery.

    4: Push and hold the "On" button on the UPS for 5 seconds

    5: Reconnect internal battery.

    6: Plug UPS in to known good power source.

    7: Turn UPS on.

     

    It works fine for me.

     

  • Hi, same problem here. Any permanent solution available? I still have warranty! Regards, Marten

  • Hi All,

    I have the very same problem. The sequence for Dead Brain problem helped, but after 3 further tests the APC USB interface was gone again. This is really not acceptable!

    I really expect a permanent solution otherwise I will return the UPS.

     

  • I am experiencing the same issues. See here.

    I do not think this ought to be marked as answered, as it is clearly a bug that affects all of these units, and having to perform the 'brain dead' procedure after any significant power-loss is clearly not an acceptable solution. The whole point of having comms with the UPS is to enable the connected systems to act on its state, which includes a power return state.

    I would very much appreciate a prompt response from APC as to whether this behaviour can, and will, be rectified. Otherwise, it renders these products unfit for purpose, and alternatives will have to be sought.

  • I agree!
    This is not a way the device should work, or how I expected it to work.
    APC should put some brains behind this issue and fix it.

    I am using apcupsd software.

    Also, I am not aware why my post was marked as answered, as it is still not solved.
    Performing the procedure is just a short-term fix, not a solution to the problem.

  • I guess it will never be fixed - may be the problem is in hardware or APC just is not bothered enough to fix it, considering this unit is low-price consumer grade model.

    Well, lesson learnt, no more APC products.

    Indeed, cheap Chinese models works way more reliable in that regards.

     

  • On 5/5/2020 8:50 AM, Alexander said:

    I guess it will never be fixed - may be the problem is in hardware or APC just is not bothered enough to fix it, considering this unit is low-price consumer grade model.

    I did not pay for the model which has a USB connection that doesn't work. When I bought the device, I took the information about the USB connection into consideration, otherwise I might have just taken a cheaper one without it...
    Why paying extra for nothing?

  • Hi,
    my BX700U is a bit over two years old.
    In the first year the USB communication worked flawlessly. I have the UPS connected to a Linux machine, sending me alerts on outages.

    Last few months I've started to see issues with connectivity. More and more frequent with time. Looks like USB port on the UPS stops working and the brain dead procedure is the only thing able to bring it back to life. I don't think there's a need for power outage to get it broken right now, it just happens few days after the reset. I've already tried two new cables, no luck.

    It seems that the BX700 series is poorly constructed. I had to exchange a battery after 15 months (and I don't have much long outages so it did not get discharged often), now the USB communication is lost. I know it's an entry level hardware, but APC brand should guarantee more quality. My next UPS will definitely be from another manufacturer...

  • If you use KILLDELAY you need to use WAKEUP - this solves problem for me.

  • This discussion is marked as answered

    I don't think it's a matter of WAKEUP.

    I'm experiencing this comms problem even when I shutdown my server with the UPS still plugged in.

    I suspect it's Linux sending some kind of USB shutdown like when removing an USB HDD.

    I never shutdown my Linux server, but last week I upgraded everything and needed to test the boot process, so I shut down several times my new Ubuntu 20 and every time, on the next boot, the UPS was not responding to USB. I figured out the UPS reset procedure myself after a couple of hours of attempts.

    I started experiencing this problem around two-three years ago when I fist upgraded from Ubuntu 14 to 16. Never had this kind of problem before. It always took me several tries to reset the USB back on (never found this thread despite searching a lot!). BTW I had already bought a second UPS (same model) and the warranty had already run out.

    If my suspect is correct, that would explain why only a small number of ppl is experiencing this: first, Windows users would not be affected, second, since it's a consumer product, not everybody is connecting to the USB port. Third, nobody shuts down a server o tests a power outage very often.

    Do you think we can ask APC to check this behaviour and release a firmware fix? I don't know how to tinker with Linux modules, but maybe we can open an issue somewhere in the comunity...

     

  • This discussion is marked as answered

    Hey APC,

    it is almost 3 years since the issue was first opened. Could you please take a look at this?

    Thanks!

Page 1 of 1 (18 items)
Choose your language:  
powered by Communifire
Version 8.0.7842.9669