Loading ...

Charging a RBC7 without UPS | Universal Transfer Switch

Home » Spaces » Universal Transfer Switch » discussion » General » Charging a RBC7 without UPS

Charging a RBC7 without UPS

Discussion in Universal Transfer Switch started by John , 11/23/2013 2:35 AM
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

Charging a RBC7 without UPS

Subscribe to RSS
  • Llewellyn

    Hi

    sorry if this is a bit late but only saw you post now. Check first if the unit is able to get power from the cable you are using by following these steps:

    Unplug the cable from the input. Hold the OFF button down until you hear the internal relays turn off (unit brain dead). You can confirm the brain turned off by checking the back of the unit, there is a small green LED which should be off. Once the unit is brain dead, plug the power cable in again. If you hear the relay turn on or brain turn on, see the green light at the back of the unit turn on you will know that it can receive power from mains. If at this stage nothing happens you could have a potential relay fault and the unit would need an internal relay replaced.

    If the brain turns on when you plug mains in I can give you some other steps to try and follow to do some further fault finding.

  • bakes99

    Thank so much for getting back to me. 

    I'm assuming that when you say to unplug  cable from the input, you mean unplug from electrical with the battery hooked up to unit, is this correct?

    When I follow your steps, I do hear the unit switch on, the green light comes on in the back "Sensitivity" and the unit lights up in the front.  When I switch the unit on, The "On Line" light flashes approx 30 or so times and the light goes out.  It remains "On Battery" showing 4/5 bars charged.

    Thanks again.

  • Llewellyn

    I believe the unit has a faulty component that needs to be repaired and you will have to take the unit into a service center to get looked at. Just to run you through whats happening. When the unit first gets switched on it goes on line - "On Line" green starts flashing green to indicate it is about to do a self test. The unit does a self test but doesn't switch back to mains operation, the self test normal runs between 3-5 seconds. So the signal is not getting back to the main micro to return to normal operation so it will continue to run on battery till exhausted.

    It would be best to have a tech look at the unit.

  • bakes99

    Purchased a replacement battery (RBC7) for my SUA1500 and it arrived today. The old one had been removed a few months ago and just now got around to replacing it.  Problem is, the UPS won't go on line power.  Only battery.  Tried a couple of things like the white button over the fuse, different outlets and been on internet better part of afternoon. to no avail.

    Not too tech savy, so just wondering if I can hook up to my 12v intelligent charger from my garage to keep it in good shape till I figure out what to do with it?  UPS is out of warranty and don't know of anywhere near me that services them.

    Any ideas would be appreciated.

    Thanks
    J

  • bakes99

    Okay so the charger doesn't work, but tried some more trouble shooting.  Just appears that no ac power is getting to my unit.  there is no difference in when I unplug or plug it in.  Could it be just a blown fuse.  If so, how do I get a replacement?  Open to any other ideas.  help!!!!!

Page 1 of 1 (5 items)
Choose your language:  
powered by Communifire
Version 6.0.7207.29305