Loading ...

UPS model BR900G-GR battery indicator goes immediately to zero (0) after 100% charge | Getting Started

Home » Spaces » Getting Started » discussion » General » UPS model BR900G-GR battery indicator goes immediately to zero (0) after 100% charge

UPS model BR900G-GR battery indicator goes immediately to zero (0) after 100% charge

Discussion in Getting Started started by Otto , 24 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
Posted in: General

UPS model BR900G-GR battery indicator goes immediately to zero (0) after 100% charge

Subscribe to RSS
  • Otto67

    Hello,

    Problem:

    When the UPS loses main power, then the battery indicator goes immediately to zero (0) and the UPS shuts down.

    Condition:

    The UPS model BR900G-GR passes the PowerChute self-test and PowerChute shows batteries fully charged.

    The UPS was manufactured in May 2016. The original Battery Pack was replaced in May 2019 (17 month in use to date).

    Actions:

    I disconnected all equipment from the Battery Backup.

    Serial port to PowerChute remains connected.

    Started the UPS power supply and checked the status in PowerChute.

    It showed that Battery charge is at zero % and it is charging the batteries. After the batteries were charged to 100% I ran the self-test again. It passed.

    Connected all loads again (ca. 270W) and removed line AC from the UPS. It shows immediately empty batteries and shuts down.

    Pulled the batty pack and checked the voltage: 26.25V

    Questions:

    What is the most likely possibility: UPS faulty or battery pack bad again?

    Any helpful comment or question will be appreciated.

    Thanks.

Page 1 of 1 (1 items)
Choose your language:  
powered by Communifire
Version 8.0.7598.8416