8 Replies Latest reply: Dec 8, 2008 11:57 AM by Kevin P. RSS

APC Smart-UPS SC 1500VA Problem

PawelPawlak Member
Currently Being Moderated
Hello.

I`ve got APC Smart-UPS SC 1500VA.
I`ve got this UPS conneced to my main PC by USB-Serial cable from APC.
This main PC has got all Powerchute Agent/Server/Console installed, and there
is no problem here - I can go 127.0.0.1:3052, Console works too.
Problems begins when I install Powerchute Agents on my two other computers.
In "Powerchute Console/Server > Configure Device List" both those computers
are detected, but it always fails to apply configuration profiles -
"Failed to Apply Configuration Profile" message.
"PC_IP_Number:3052" webpage works over LAN.
More interesting thing is that, when I connect my old computer
(that have serial port) with UPS using Serial-Serial cable,
and this old computer acts like a server - everything works
without a flaw. So it is probably error that have something to do with
Serial-USB converter cable.

Regards,

Pawel Pawlak
  • 1. Re: APC Smart-UPS SC 1500VA Problem
    CMFR Apprentice
    Currently Being Moderated
    Hello:

    When you connect to it on http://localhost:3052, can you actually view the UPS's status and such? And confirm that there is communication?

    What version of Java is installed on this computer?

    Thanks.
  • 2. Re: APC Smart-UPS SC 1500VA Problem
    PawelPawlak Member
    Currently Being Moderated
    Hello.

    Let`s say I`ve got 3 systems in LAN:
    192.168.1.11 - Agent/Console/Server installed - direct Serial connection to Smart-UPS 1500VA - Win XP Pro SP3
    192.168.1.12 - Agent installed - Win XP Home SP3
    192.168.1.13 - Agent installed - Win XP Pro SP3

    Powerchute 7.0.4 Business Edition Basic used (max. 5 Nodes)

    From any to any LAN computer I can connect to this webpage http://LAN_IP:3052.
    Only on 192.168.1.11 port 3052 webpage there is info that there is connection with Server.
    192.168.1.12/13 there is webpage but it`s stated that there is no connection to the Server.
    I can PING any computer in LAN too.
    Windows Multicast messages works on all computers.
    Windows Firewall is off in all computers.
    I have Avast on all 3 systems, but stopping it`s services did`nt helped.

    When I want to add 192.168.1.12 and 192.168.1.13 PC that have
    only agents installed - this systems are found and Listed in Console
    Device List - but when I want to add them there is always
    "Failed to apply the configuration profile" message displayed.

    I heve tried earlier USB-Serial link from UPS to Server PC now
    I switched to Serial-Serial, but results are the same.

    On all 3 PC I have newest Java (1.6.0 u11) installed.

    I`ve tried already to install Server/Console on two from three my PC.
    Agent always only worked only on machine with Console/Server
    installed and UPS directly connected to it.

    Regards,

    Pawel Pawlak
  • 3. Re: APC Smart-UPS SC 1500VA Problem
    PawelPawlak Member
    Currently Being Moderated
    Still no success.
    Like I wrote earlier:
    PowerChute Server can discover and list Powerchute
    Agents in LAN, but it can`t apply configuration to them.
    Only one PowerChute Agent that Server can comunicate with
    is one on the same computer PowerChute Server is.

    Waiting for Your help guys...

    PP
  • 4. Re: APC Smart-UPS SC 1500VA Problem
    PawelPawlak Member
    Currently Being Moderated
    Still no fix,
    but
    I have found that there are little
    differences in "Agent" folder on computer
    where it is installed alone comparing to
    same folder where it`s installed with
    Server/Console.
    In "agent>lib>win32" folder
    of computer where Server/Console
    is also installed
    there are
    natcomm.dll, win32com.dll
    files that are absent on Agent only computer.
    In the same folder of Agent only computer
    there is
    apcusb.dll
    that is nowhere on other computer.

    Regards,

    PP
  • 5. Re: APC Smart-UPS SC 1500VA Problem
    Cap1 Apprentice
    Currently Being Moderated
    I'm not sure about your exact situation, but I've seen many of these cases resolved by just uninstalling 7.0.4 and installing 7.0.5. However, these are no longer available, so its a situation of what you have now is all you can get. Unless you go to 8.0.0 in which case would be a purchase for the server portion.
  • 6. Re: APC Smart-UPS SC 1500VA Problem
    PawelPawlak Member
    Currently Being Moderated
    Installed 7.0.5 too - no effect.

    PP
  • 7. Re: APC Smart-UPS SC 1500VA Problem
    PawelPawlak Member
    Currently Being Moderated
    I`m not going to surrender so easily...

    Ive installed sniffer and intercepted TPC/IP communication between
    PC where is PoweChute Server installed and PC on where PowerChute Agent is (in the moment I`m trying to apply configuration data to it).
    Of course I`m not Software Engineer, so I need to send this data to someone that will be able to identify what is going on.

    Anyone?

    PP
  • 8. Re: APC Smart-UPS SC 1500VA Problem
    Kevin P. Apprentice
    Currently Being Moderated
    PawelPawlak wrote:
    Hello.

    I`ve got APC Smart-UPS SC 1500VA.
    I`ve got this UPS conneced to my main PC by USB-Serial cable from APC.
    This main PC has got all Powerchute Agent/Server/Console installed, and there
    is no problem here - I can go 127.0.0.1:3052, Console works too.
    Problems begins when I install Powerchute Agents on my two other computers.
    In "Powerchute Console/Server > Configure Device List" both those computers
    are detected, but it always fails to apply configuration profiles -
    "Failed to Apply Configuration Profile" message.
    "PC_IP_Number:3052" webpage works over LAN.
    More interesting thing is that, when I connect my old computer
    (that have serial port) with UPS using Serial-Serial cable,
    and this old computer acts like a server - everything works
    without a flaw. So it is probably error that have something to do with
    Serial-USB converter cable.

    Regards,

    Pawel Pawlak
    Maybe I'm missing something here, can you go over your physical communication paths again?

    So far, based off this, all I can see is you have an SC1500 connected via USB to Serial bridge to a PC
    You then state that you installed the Agent on 2 other machines, however, never stated what physical type of communication, if any, there is back to the UPS.

    Please confirm.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 8 points
  • Helpful Answers - 4 points