Loading ...
Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Powerchute Business v9.5 & Windows Server 2016

Powerchute Business v9.5 & Windows Server 2016

Discussion in UPS Management Devices & PowerChute Software started by KK , 15 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
  • KKChiu
    KK
    Novice Novice
    KK 15 days ago

    Is Powerchute Business Edition ver.9.5 compatible to Windows Server 2016?

    What is the difference between Powerchute version 9.2 and version 9.5?

    Thanks for any help in advance :)

  • wpasquil
    Bill
    =S= Representative
    Bill 12 days ago (in response to KK)

    Hi,

    Yes. PCBE 9.5 is compatible with Window Server 2016 The differences are listed in the release note attached. 

    The most notable differences are, the Server and Console components have been removed. Added support for SNMP. Added support for SMTP SSL/TLS. 

    Attachments
  • KKChiu
    KK
    Novice Novice
    KK 11 days ago (in response to Bill)

    Thanks for the advice.

    BTW. Do I need to uninstall Powerchute 9.2 first before installing Powerchute 9.5 on Windows Server 2016?

  • wpasquil
    Bill
    =S= Representative
    Bill 11 days ago (in response to KK)

    Hi,

    The installer will run an update if you do not want to uninstall version 9.2. If you do upgrade the new security feature requiring strict compliance to user name and password security does not get loaded since the old version did not require them. If in the future you do uninstall 9.5 and reinstall you will be required to adhere to the new user name and password requirements. 

    PCBE 9.5 Username and Password Requirements

    • The username must be between 6 and 128 characters in length.
    • The password requires:
    – Minimum 8 and maximum 128 characters in length.
    – One upper and lower case letter.
    – One number or special character.
    • The username cannot be part of the password.
  • Page 1 of 1 (4 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692