Loading ...
Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » What now after ESXi PCBE install?

What now after ESXi PCBE install?

Discussion in UPS Management Devices & PowerChute Software started by John , 10 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
  • jvold
    John
    Novice Novice
    John 10 days ago

    OK, this is probably the dumbest question ever but... what do I do now? I've installed the vMA on the ESXi host, installed PCBE via the command line. How do I access the PCBE software? Is there some sort of utility where I can make changes, setup rules, see statuses, etc.? Can I install this my PC or does this need to be installed on one of the VM's?

    Thanks.

  • wpasquil
    Bill
    =S= Representative
      This discussion is marked as answered
    Bill 10 days ago (in response to John)

    Hi,

    PowerChute Business Edition Agent has a web browser interface. Open your favorite web browser on your PC and enter https://ip address of the vMA:6547. Example https://192.168.1.10:6547 The Agent will launch and you can access and configured the application/UPS. 

  • jvold
    John
    Novice Novice
    John 9 days ago (in response to Bill)

    Perfect, thanks!

    Unfortunately it says "Communication not established" so is there a troubleshooting guide I can look at somewhere before starting a new thread?

  • wpasquil
    Bill
    =S= Representative
    Bill 9 days ago (in response to Bill)

    Hi,

    You should review the documents attached to Schneider Electric FAQ FA165747

    99% of the time the issue is the serial port is not configured properly. You should check to verify the proper port has been selected in PowerChute. The proper port is set in the vMA and is dedicated to the vMA. Setting up the serial port in the vMA is discussed starting on page 9 of the configuration PDF. 

  • jvold
    John
    Novice Novice
    John 9 days ago (in response to Bill)

    Yes, thanks, that is the document I've been following to get where I'm at. So, when you say to check powerchute, you're referring to the web console you pointed me to previously, yes? And, the vMA is obviously configured in the vSphere client. I can't remember now at this point, but was there anything in the pbe agent command line install (linux) where you had to select the serial port? Is there any way to check those settings rather than re-installing? And if I need to re-install it, do you have to uninstall first?

  • jvold
    John
    Novice Novice
    John 9 days ago (in response to John)

    Just to provide some more info...I have a Dell Rackmount server with a single serial port running ESXi 5.1. I used the supplied cable to connect the server serial port to the RJ-45 serial port on the back of the UPS. I have tried setting the serial port in both the vMA settings and PCBE settings as suggested above. I have tried both on ttys0, and ttys1, rebooting the server between changes, and neither one works at this point. I googled a linux serial command (see attached). Doesn't that mean that the linux server can see the serial port correctly?

    Attachments
  • wpasquil
    Bill
    =S= Representative
    Bill 9 days ago (in response to John)

    Hi,

    Would you provided a screenshot of the virtual machine properties and how many uart ports are listed in the drop down?

  • jvold
    John
    Novice Novice
    John 9 days ago (in response to Bill)

    Sure thing...

    Attachments
  • wpasquil
    Bill
    =S= Representative
    Bill 8 days ago (in response to John)

    Hi,

    Troubleshooting will take a bit of time since your host system shows 2 possible port options and the vMA has 2 possible ports. 

    I am making the assumption that you have PowerChute installed to the default path of /opt/APC/PowerChuteBusinessEdition/Agent.

    Since you have PowerChute configured with ttyS0 on the vMA and the vMA is configured for uart0 you should first try ttyS1 on the vMA. To switch ports from within PowerChute cd to /opt/APC/PowerChuteBusinessEdition/Agent then enter the command sudo service PBEAgent stop. PowerChute will be stopped. Then enter sudo ./config.sh You will be asked to enter the user name and password assigned to PowerChute. You will then be asked if you want to change the user name and password. You should select no. The next question is to choose the com port. Select ttyS1. When asked to enter the host information select q and then select to start PowerChute. Finally open the PowerChute web interface and check to see if communication has been established. 

    If communications is still not established follow the steps above and switch the port back to ttyS0. Then power off the vMA. The command is sudo init 0 (zero). Once the vMA has powered down go to Virtual machine Properties. Select Serial port 1 and change uart0 to uart1 and click ok. Then restart the vMA and log into PowerChute to verify that communications has been established. If communications is not established not follow the instruction above and switch the vMA port from ttyS0 to ttyS1. 

  • jvold
    John
    Novice Novice
    John 8 days ago (in response to Bill)

    Thank you so much for your help. However, it still is not working. One thing I want to double-check before proceeding further is that I have "Smart" selected instead of "Simple", is that correct?

    Anyways here are the following configurations I have tried following your instructions above:

    VMA = uart0, PCBE = ttyS1

    VMA = uart0, PCBE = ttyS0

    Stopping/staring the service each time for the change. Since that didn't work I powered off the VMA and changed the serial port to uart1 and tried:

    VMA = uart1, PCBE = ttyS0

    VMA = uart1, PCBE = ttys1

    Any other ideas?

    Thanks.

  • wpasquil
    Bill
    =S= Representative
    Bill 7 days ago (in response to John)

    Hi,

    When the serial port is set to uart0 does it show connected in Virtual Machine Properties or does it show connected when set for uart1?

    When you installed PowerChute did you select RJ45 when asked about the connection type?

    When you launch the PowerChute web interface is the menu bar blue or green?

    On 9/14/2017 12:13 PM, John said:

    One thing I want to double-check before proceeding further is that I have "Smart" selected instead of "Simple", is that correct?

    The UPS is an SMT so it is Smart signalling. You should connect the serial cable that came with it which is DB9 to RJ45. The RJ45 end need to be plugged into the port labeled UPS communication port on the back of the UPS.  

  • jvold
    John
    Novice Novice
    John 7 days ago (in response to Bill)
    On 9/14/2017 2:23 PM, Bill said:

    When the serial port is set to uart0 does it show connected in Virtual Machine Properties or does it show connected when set for uart1?

    Yes, to both, as in there is a checkbox that says "Connected" and it is checked.

    On 9/14/2017 2:23 PM, Bill said:

    When you installed PowerChute did you select RJ45 when asked about the connection type?

    Yes.

    On 9/14/2017 2:23 PM, Bill said:

    When you launch the PowerChute web interface is the menu bar blue or green?

    Blue.

  • wpasquil
    Bill
    =S= Representative
    Bill 6 days ago (in response to John)

    Hi,

    If the menu bar is blue than the wrong version has been installed. The correct version should be 9.2 or 9.2.1. I assume the version that is installed is 9.0.3 or 9.0.4. To correct you should uninstall and reinstall. The command to uninstall is sudo rpm -e pbeagent. When you reinstall select the connection type of RJ45.

    I also suggest you switch the vMA back to uart0 and ttyS0 if you have not done so already.

     

  • jvold
    John
    Novice Novice
    John 4 days ago (in response to Bill)

    I'm up and running, thanks so much!

    Uninstalled the old version (9.1.1) and installed the new 9.2 version (got the green bar laughing)

    Had to switch the vMA to uart1 instead of zero and keep ttyS0.

  • Page 1 of 1 (14 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692