Loading ...
Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Powerchute Business 9.x shutdown command line doesn´t work

Powerchute Business 9.x shutdown command line doesn´t work

Discussion in UPS Management Devices & PowerChute Software started by Udo , 8/3/2017 3:57 PM
Login to follow, share, and participate in this space.
Not a member?Join now
  • budspencer
    Udo
    Novice Novice
    Udo 8/3/2017 3:57 PM

    Hi,

    I´m running pcb 9.x on a windows server. The UPS is Samrt UPS 750. It´s connected via serial Cable an works fine. What I ant to do is the following:

    I want to shut down plink.exe (ssh) an synology disk station in case of power failure. When I start the executable from the command line: C:\plink.exe -ssh -pw passwortdiskstation root@192.168.8.6 poweroff The Synology Disk Station powers off. The Problem is: I can´t do this in PCB. When testing the Command line, nothing happens. I´ve also tried this:

    3. If the test fails, go to Services and right click on the Agent service and choose Properties.

    4. Click on the "Log On" tab.

    5. Check the box for "Interact with Desktop". 

    When I do this, communication between server and upc is lost.

    Any Idea?

    Thanks.

  • wpasquil
    Bill
    =S= Representative
    Bill 8/3/2017 5:01 PM (in response to Udo)

    Hi,

    The issue may be resolved by adding @start to the command line as listed in FAQ FA168226. If that does not resolve the issue the cause most likely is due to PCBE is a service and ever since Windows Vista was release anytime a service attempts to run an executable it must be started in session zero. More information on session zero is noted in FAQ FA168226.

    there are a few post here that discuss work arounds. I suggest reviewing Kenneth's post dated 26 April 2015 

    http://forums.apc.com/spaces/7/ups-management-devices-powerchute-software/forums/general/3033/pcb-shutdown-command-file-doesn-t-execute

    There is another work around listed in this post 

    http://forums.apc.com/spaces/7/ups-management-devices-powerchute-software/forums/general/12714/-fyi-how-to-run-executable-in-user-session-from-service-session-0

  • budspencer
    Udo
    Novice Novice
    Udo 8/3/2017 6:09 PM (in response to Bill)

    Hi Bill,

    I´ll check this out. May take some time. Will be back as soon I´ve tried out.

  • budspencer
    Udo
    Novice Novice
    Udo 8/12/2017 5:34 PM (in response to Bill)

    Hi Bill,

    I´ve taken a closer look to Kenneth´s post dated 26 April 2015.

    "

    I'm late to this party, but I encountered the exact same problem and figured out a work-around: use the Windows Task Scheduler!

    1. Create a task that executes whatever you'd like (I tested with shutdown /i), set a suitable user account for running it (I picked my user account) and check "Run with highest privileges" if necessary (not necessary for my test), and allow it to be started manually. Give the task a suitable name, e.g. ShutdownTest.
    2. Create a script for PowerChute to execute, and add this line: @start schtasks /run /tn ShutdownTest
    3. Execute it from PowerChute and watch it work ;)"

     

    I´ve tried to Create an new Scheduled Task with the GUI Scheduled Task planer. I wasn´t able to find the option "start manually". As far as I´ve understood I have to add this line "@start schtasks /run /tn ShutdownTest" to my existing cmd file for getting scheduled task planer into interaction with the cmd file.

    Question: How do I do this in conrete?;)

    Thanks.

  • budspencer
    Udo
    Novice Novice
    Udo 8/13/2017 4:25 PM (in response to Udo)

    I think I got it going like Kenneth...;)

    Thanks a lot!

  • Page 1 of 1 (5 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692