Loading ...
home » spaces » UPS Management Devices & PowerChute Software » discussion » General » Powerchute Business Edition Basic - Failed to apply config profile w/AP9607

Powerchute Business Edition Basic - Failed to apply config profile w/AP9607

Discussion in UPS Management Devices & PowerChute Software started by Chris , 9/18/2009 2:37 PM
Login  to follow, share, and participate in this space.
Not a member?Join now
  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 9/18/2009 2:37 PM

    We have a Smart-UPS 1500VA with two Windows 2003 servers and one Windows XP Pro server sucking power through it. One 2003 server is a DC, the other a NAS. The XP server is a Proxy and AntiVirus server. The DC is connected directly to the UPS VIA serial port. The Proxy & NAS are connected to the UPS's AP9607 Interface Expander VIA serial ports with the supplied cables. We are running PowerChute Business Edition Basic 7.0.2 build 110 (The software CD that came with the UPS) with the Agent/Server/Console on the DC. The Agent is also installed on the Proxy and NAS, along with the console on my desktop PC so I can administer everything without having to log into the DC.

    In the Device list Configuration wizard, the Proxy & NAS are visible under Discovered Devices - but when added to Current Device List fail with the error "Failed to apply the configuration profile to servername.domainname.local". therefor, I am unable to get the other two servers to gracefully shutdown. When we had a power failure several days ago, our DC gracefully shut down, but the Proxy & NAS went down hard. I've had problems with this happening in the past and resorted to using a command file to shut down the two servers over the network (since our backbone is on another UPS). Unfortunately, it seems that this took a hike also.

    In the Powechute Console, under Tools> Configure Device List, I can see the other 2 servers where I installed the agent under the Discovered Devices, but the problem is when I'm trying to add them to the Current Device List and hit "Apply" button, there's always an error saying "Failed to apply the configuration profile". Obviously the Console detects the other servers with agent installed but I can't add them to the Current Device List.

    I've tried using command files (see this thread: http://forums.apc.com/spaces/15/universal-transfer-switch/forums/general/4935/helping-me-go-green-ups-suggestion) to shut down the servers, but this stopped working out-of-the-blue. It's been over a month trying to get the command files working but it looks like APC support has abandoned me, and apparently nobody else on this forum has a clue what's going on since I've gotten no responses.

    I need SOME sort of solution. We purchased this card and I'd like to get it actually working. I liked the command files because I was able to shut down other PCs on the network that were connected to a "dumb" UPS, but since that no longer works I believe it's time to get the AP9607 playing nice with the servers.

    Help would be appreciated.

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 9/23/2009 5:40 PM (in response to Chris)

    Nobody? Really?

  • PowerMan
    Joel
    =S= Representative
    Joel 9/23/2009 6:52 PM (in response to Chris)

    Hi Chris,

    There are several causes of the failed to apply the configuration profile error. Here is a kbase article that goes over most of them. http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/std_adp.php?p_faqid=2596.

    Also, all of the different versions of PowerChute are very reliant on Java and I've seen old versions of Java cause this as well. I would suggest uninstalling all the components of the software, updating Java and then reinstalling PCBE, this will also give you a chance to verify the user name and password as mentioned in the kbase article. The version of Java that comes with Windows is not a full version of Java so when you update it go to http://www.java.com/en/ to verify you are getting the full version.

    If you want to shutdown more servers then I would suggest looking into a Network Management Card (NMC). With a NMC you can shutdown your systems over the network using PowerChute Network Shutdown with no need for the serial cables. Here is a link to the NMCs, http://www.apc.com/products/family/index.cfm?id=98.

  • Techie
    Bala
    =S= Representative
    Bala 9/23/2009 9:31 PM (in response to Joel)

    Hi Chris,

    If possible, could you please confirm me the Serial Cable part number which is attached between the Interface Expander Serial ports and the Servers?
    You can find the cable part number on the connector itself.

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 9/24/2009 2:25 PM (in response to Joel)

    I've looked at that sheet and unfortunately none of them seem to apply to us.

    Uninstalling/reinstalling/messing with Java is not an option. This could jeopardize both our backup and our anti-virus (both Symantec java-based products).

    The serial cables P/N is 940-0023A and came with the AP9607 when purchased.

  • Techie
    Bala
    =S= Representative
    Bala 9/25/2009 10:47 AM (in response to Chris)

    Chris,

    The AP9607 has got 2 Basic monitoring ports. Thus, it requires the basic simple signaling cable to be connected between the Expander serial ports and the Servers.

    Click on the below link and refer the page#4 to know the supported serial cable part numbers for your application.
    http://www.apcmedia.com/salestools/ASTE-6Z5Q9H_R0_EN.pdf

    You can see a lot of useful information about this card in the user manual.

    I hope that this helps.

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 9/28/2009 12:45 PM (in response to Bala)

    Oh awesome, so the AP9607 didn't come with the correct cables. Upon looking at the manual, the cables it came with aren't even listed in there. I have two 940-0023A cables that came with the interface expander that apparently go to nothing. It seems to me that APC owes me a pair of the correct cables.

    Go APC.

  • Techie
    Bala
    =S= Representative
    Bala 9/28/2009 2:50 PM (in response to Chris)

    Chris,

    As far as I know, the AP9607 does not ship with the Simple Signaling cables. The supported Serial Cables need to be purchased separately. The Tech Specs link says that the it only ships with user manual. [http://www.apc.com/resource/include/techspec_index.cfm?base_sku=AP9607]

    Secondly, the PCBE software does not support NAS and Proxy Servers. Please view the PCBE OS Compatibility chart in the below link:
    [http://www.apcmedia.com/salestools/ASTE-6Z5QEV_R10_EN.pdf]

    You may also refer the below Application notes which provides technical information regarding APC UPS computer interface ports. This information is for customers attempting to use the port for unsupported purposes.
    [http://www.apcmedia.com/salestools/TDOY-5UQVBL_R1_EN.pdf]

    And also I leave this thread to other folks in the forum to offer some solution to shutdown NAS and Proxy Servers gracefully in the event of power failure.

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 9/28/2009 3:42 PM (in response to Bala)

    Our APC9607 shipped to us with the cables, users manual and some other random paperwork. I still have the box and everything that came with it, so I'm not exactly sure about that?

    Also, how does PCBE not support NAS or Proxy servers? Our NAS runs Server 2003 R2 which is supported, and our proxy runs Windows XP Pro SP3 which is also supported. So if I shared files on our DC or put windows-based proxy software on the DC; it would suddenly become an "unsupported" device?

    Since I have the pinouts for the 940-0020 cable, I've just decided to have two built in our electronics manufacturing facility. I'm hoping with the correct cables this will work correctly.

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 9/28/2009 7:28 PM (in response to Chris)

    Alright, I have searched through the building and found a few dumb UPSs. I have a 940-0020B cable and a 940-0020C cable. I have hooked both up between the APC/Servers and I'm still having the same problem. I attempt to add the devices to the configuration profile, and to no surprise they fail.

  • Techie
    Bala
    =S= Representative
    Bala 9/29/2009 12:01 PM (in response to Chris)

    Okay..the 940-0020C or B cable is Simple Signaling Cable. Therefore, the Power Chute Business Edition Agent component will not detect the UPS automatically while installing it. Please make sure that you select the appropriate COM port manually and specify "Simple Signaling Accessory" during the installation process.

    Once you installed the PCBE agent, kindly check if you are able to access the agent to make sure that portion is communicating between UPS and agent service. In order to do this, on each machine you have the agent installed and running, you need to go to the loop back address: [http://127.0.0.1:3052] (or the appropriate IP address if accessing form a local machine). The agent service operates on port 3052. You need to have java installed for this to work. You should get a username and password prompt in order to login to the web browser. This will verify the communication between the agent and the UPS to rule out that problem.

    I hope that it helps.

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 10/2/2009 3:26 PM (in response to Bala)

    I am able to log in and view/edit settings for the agent on both servers connected to the AP9607. I'm editing the settings to point to Simple signaling and I'm going to see what happens here.

  • Techie
    Bala
    =S= Representative
    Bala 10/2/2009 4:10 PM (in response to Chris)

    Chris,

    I am glad that you are able to access the PCBE agent web interface on both the servers. Please let me know if you have any question.

    Have a nice day!

  • ChrisInVT
    Chris
    Novice
    Novice
    Chris 11/26/2009 6:17 PM (in response to Bala)

    Edit: Nevermind.

    Message was edited by: ChrisInVT

  • Page 1 of 1 (14 items)
powered by Communifire
Version 4.7.5466.29801
Choose your language:  English