Loading ...
Home » Spaces » UPS Management Devices & PowerChute Software » discussion » General » Does anyone have e-mail working with the AP9631 / 6.4.6 firmware

Does anyone have e-mail working with the AP9631 / 6.4.6 firmware

Discussion in UPS Management Devices & PowerChute Software started by Matt , 3/18/2017 5:59 AM
Login to follow, share, and participate in this space.
Not a member?Join now
  • MattCarpenter
    Novice Novice
    Matt 3/18/2017 5:59 AM

    I just updated the firmware on my AP9631, which is plugged into a Smart-UPS 1500.

    Previously, I had e-mail notifications working, connecting to an encrypted smtp mail server on port 587.

    This no longer works for me.

    I did wireshark traces and discovered that the e-mail communications is being attempted on port 25!!

    I have attached my e-mail settings.

    Can APC or anyone else confirm that this is a bug?

    Is it possible for me to get firmware version 6.4.0 for the AP9631 and SmartUPS-1500?  There's another related message on this forum that someone was successful in getting this working with v6.4.0.

  • ipicKedawinna
    =S= Representative
    Angela 3/20/2017 4:36 PM (in response to Matt)

    Email itself is thoroughly tested every release. So, I feel like there could be a problem with the recipient settings that was somehow caused, either by the upgrade or inadvertently. 

    Can you show a screenshot of your email recipient's setting? I am referring to under Configuration->Notification->Email-> Recipients->click on recpient that is not receiving email.

    Thanks! I am most interested to see if the Server option is set properly. It looks like it should be set to Local but maybe it is on something else and not using those settings you've shown in your screenshot.

  • ipicKedawinna
    =S= Representative
    Angela 3/20/2017 4:39 PM (in response to Angela)

    I forgot to add, we have no problem providing the older firmware to you but I am not convinced that is necessarily what will fix this. I work with this product each day so I am thinking if email flat out did not work, I'd probably have heard about it by now embarassed

  • MattCarpenter
    Novice Novice
    Matt 3/21/2017 12:17 AM (in response to Angela)

    Hi Angela,

    I'm glad you picked up this issue, since in doing the research on it, I've seen that you've been the expert on it on other support requests.

    I agree, I was surprised that it wasn't working, since it worked before the upgrade.   I don't remember exactly, but I think I was running 5.x before the upgrade.

    The reason I stumbled on this was, after the upgrade, I was receiving an error message on the e-mail test.   The error was that my ISP (in this case a Charter, residential service) was refusing communications on port 25.   It is an interesting "spam blocking" filter.   Initially I was confused by this, since, I've never seen this before.   My normal e-mail client (on the same LAN) could send mail without a problem, and, my APC settings clearly indicate port 587/SSL communications.

    I thought about the error message from the test further and decided to pull out wireshark.   I confirmed what the e-mail error test was telling me:  the outbound communications was attempting to be sent on port 25!

    (Regarding the e-mail server settings, @me.com, @icloud.com, and @mac.com are all the same Apple domain.   I tried different combinations, thinking it was some sort of server authentication error.  I should have paid closer attention to the error message, since it indicates that it's a block on port 25 communications.   Again, my Mac, which is what is plugged into my APC, uses Apple's e-mail client, which communicates on port 587.   All of this worked before my last firmware)

  • ipicKedawinna
    =S= Representative
    Angela 3/21/2017 2:00 PM (in response to Matt)

    Hi Matt,

    Upgrading from v5.X to v6.X is a major upgrade so I think that because we have some new settings, something may have gotten messed up in the carry over - either due to the upgrade mistakenly based on your v5.X settings, a bug I can't remember, or I am not sure if you were tinkering with the settings at all.

    I think I do see the problem though. For your recipient in your first screenshot, see how it is set to Recipient? This is incorrect. That setting means that it forces port 25 and tries to track down the email server based on your email recipient's domain (so @mac.com). This method does not use authentication either. You want it to use the settings from the local server you've programmed in and showed me on your original post. I recommend you click into your recipient settings and change the server setting from recipient to local, as shown below in my example. Please then retest and let me know how it goes.

    Click on recipient and change this in drop down menu:

    And then it should look like this. Then do your SMTP test again.

    Hope it fixes it laughing glad to help.

  • MattCarpenter
    Novice Novice
    Matt 3/21/2017 5:07 PM (in response to Angela)

    Wow!   I didn't realize (or must have forgotten) that each recipient has the possibility of its own e-mail server settings.

    I suppose by setting the Recipient's Server to Local, the NMC will use the "default" e-mail server settings.

    Ok - I've made that change.   The good news is that I'm now able to talk to my e-mail server!   No more filtering from my ISP's Spamhaus.

    The bad news is that it's still not working.   I've tried all combinations of "Use SSL/TLS" and it's not getting through.

    When I test on 

    Never - I get an immediate error "530 5.7.0 No STARTTLS command has been given."

    If supported - I get "220 2.5.0 Go ahead with TLS negotiation".   This requires the test web page to refresh ~5 times, then I actually have to access the test page again to see the server response.

    Always - I get "220 2.5.0 Go ahead with TLS negotiation"

    Implicitly -I get "No data."   This looks to me that the e-mail server was waiting and timed out.

    I decided to navigate to the "Control > Network > Reset/Reboot" menu item and reboot the AP9631.   I was able to log back in within 1 minute (it rebooted fast).   This had no effect.

    I have no SSL certificates loaded.   Require CA Root Certificate is UN-checked.   I don't think these settings would have an effect?

    I appreciate your help, but this is a head scratcher!   But, we made some progress in that we're now talking to the e-mail server.

  • MattCarpenter
    Novice Novice
    Matt 3/26/2017 10:39 PM (in response to Matt)

    Well, I've given up on using an Apple e-mail server.   I switched to another e-mail server that does not use encryption - it communicates (and authenticates) in plain text on port 25.   This works.

    I would ask that you please do report this to a developer.   Someone there must have an iPhone and should be able to test encrypted communications from the AP9631 on port 587.

    Thank you!

  • Page 1 of 1 (7 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692