Loading ...
Home » Spaces » Back-UPS & Surge Protectors » discussion » General » APC Back-UPS Pro 900 doesn't work correctly?

APC Back-UPS Pro 900 doesn't work correctly?

Discussion in Back-UPS & Surge Protectors started by Jan , 13 days ago
Login to follow, share, and participate in this space.
Not a member?Join now
  • equinox
    Jan
    New Member New Member
    Jan 13 days ago

    Hello,

    I bought a new APC Back-UPS Pro 900 but it probably doesn't work correctly (I never owned a UPS before). 

    Sometimes it doesn't power up, sometimes it does. When it doesn't the LCD panel only flashes for a brief moment and the device itself does nothing if the start button is pressed. And when it does it works correctly. I found out that it probably depends on the placement of the battery.

    For example if I remove the battery and insert it in again it powers up normally when turned on. Then I turn off the device a move it to the pc (e.g. just a few meters from kitchen to my room) and it doesn't power up anymore. So I think the device is prone to any little displacement or pushing - there must be some broken connection between the battery and the rest of the device - or not?

    I suppose it isn't a correct behavior of the UPS, right?

    Should I make another complaint and demand a complete device replacement or is there something else I'm overlooking?

    Additional notes:

    * Tried different sockets in my house.

    * Doesn't matter if the device is plugged into a socket or not.

    * Doesn't matter if there is something connected to the device or not.

    * When I am lucky and the device powers up it shows fully a charged battery without any errors/beeping. Futhermore, the device charges correctly anything connected to it (with the device itself plugged or unplugged). But does nothing if the screen just flashes.

    * I already settled the complaint and got battery replaced, but it didn't work. The problem still persists.

    Gif of the problem:

    https://imgur.com/cKEGuF7

    Thanks for any help.

  • wpasquil
    Bill
    =S= Representative
    Bill 12 days ago (in response to Jan)

    Hi,

    Sorry for the inconvenience. You should contact local support. They may ask you to run a few test and if they fell the unit is defective they will issue a replacement. Local support contact information can be found at this link http://www.apc.com/cz/cs/support/contact-us/index.jsp

  • Page 1 of 1 (2 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692