Loading ...
Home » Spaces » Back-UPS & Surge Protectors » discussion » General » Weird Alarm Condition on ES-350 That's Not Listed in the Manual... Sometimes

Weird Alarm Condition on ES-350 That's Not Listed in the Manual... Sometimes

Discussion in Back-UPS & Surge Protectors started by gregg , 7/28/2017 2:37 AM
Login to follow, share, and participate in this space.
Not a member?Join now
  • opr8r
    gregg
    New Member New Member
    gregg 7/28/2017 2:37 AM

    Ok, I have determined a work-around for this so it's no longer a matter of function/concern, but now just curiosity. After a battery replacement that I will no go into here for lack of time and space I have been seeing a strange alarm condition that doesn't match anything in the manual, a continuous alarm tone with ONLY a steady (2 per second or so) flashing green "Power On" light. My manual states 3 "light states" that might coincide with a continuous alarm tone, namely: 1) A flashing red "Replace Battery" light =  Battery disconnected, 2) Alternating green "Power On" and red "Replace Battery" lights flashing = Battery in need of Charge/Battery at end of service life, or 3) No lights flashing at all = Overload shutdown. NONE of these issues exist. I know my red "Replace Battery" light functions 'cuz I can force the conditions necessary to illuminate it so it's not that. Again, I get a continuous alarm tone and ONLY the green "Power On" light flashing. Any thoughts?

  • Page 1 of 1 (1 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692