Loading ...
Home » Spaces » Universal Transfer Switch » discussion » General » UTS6H - LCD Display

UTS6H - LCD Display

Discussion in Universal Transfer Switch started by Michelle , 12/24/2016 9:50 PM
Login to follow, share, and participate in this space.
Not a member?Join now
  • medtech1
    Michelle
    Novice Novice
    Michelle 12/24/2016 9:50 PM

    I noticed today the LCD display on my UTS6H transfer switch was screwed up.  

    If I reset the switch (turn off all power) and restart, its ok for a while but then it happens again.

    Is this a bug or something? ideas?LCD

  • medtech1
    Michelle
    Novice Novice
      This discussion is marked as answered
    Michelle 12/31/2016 8:53 PM (in response to Michelle)

    I think I can answer my own question. I ran a 30A generator feed (2 x 10AWG) via EMT using the top 1/2" hole, on the right side of the main board, passing by the logic board and to the terminal block (bottom right).

    There had to be some sort of emissions back fed from those wires that caused interference as it passed by the logic board. This made sense as a restart of the APC cleared the issue, but only temporarily. Once moved the EMT (and conductors) to the bottom right 3/4" hole (and not passing by the logic board at all), the problem went away.

     

    The APC had been mounted for over a year with no issues, and the generator fed the APC out of the back (into the garage where the generator usually was). We had concern over the carbon monoxide running the generator in the garage, and decided to run 40ft of 10/2 cable to our back stair where the generator can sit outside (and well vented).

    Attachments
  • Page 1 of 1 (2 items)
Choose your language:  
powered by Communifire
Version 5.2.6420.11692